Foreman-ansible - types of connection

Hello all :smiley:

Quick question, I see there's a commit on foreman-ansible to support winrm.
I've been trying to use it with no success. I'm setting the parameter
"ansible_connection" to winrm, but when running the role, the foreman still
tries to connect over ssh.
Do I need to configure anything else?
Also, should the "local" connection type be also supported? When trying to
use local connection, the foreman also tries to connect over ssh…

Quick yes/no question on an unrelated topic, does the plugin support using
vault password / vault password files?
Could be handy and I would be willing to work on it if someone's willing to
give me some help (I'm new to Ruby).

Thanks!

Hello Bernard,
what version of foreman-ansible are you running? As far as I know there
wasn't a new release since the winrm support was added, so unless you're
running from git checkout it won't work.

Briefly looking at the code, the commit adding winrm support should also
enable using the local connection adapter, but I would refrain from doing
that. You might end up with roles being applied on wrong host, depending on
whether you use smart proxies for ansible or not

I think there's no support for vaults yet, but it would be a great addition.

Adam

··· On Mon, Jan 2, 2017 at 11:59 PM, Bernard Landon wrote:

Hello all :smiley:

Quick question, I see there’s a commit on foreman-ansible to support winrm.
I’ve been trying to use it with no success. I’m setting the parameter
"ansible_connection" to winrm, but when running the role, the foreman still
tries to connect over ssh.
Do I need to configure anything else?
Also, should the “local” connection type be also supported? When trying to
use local connection, the foreman also tries to connect over ssh…

Quick yes/no question on an unrelated topic, does the plugin support using
vault password / vault password files?
Could be handy and I would be willing to work on it if someone’s willing
to give me some help (I’m new to Ruby).

Thanks!


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at https://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.

Hi Adam,

Thanks for your answer.
Indeed I built new gems from git hub and added them to the foreman gems.
Here again, I'm not so familiar with Ruby but I suspect it worked since I
see the new settings under settings->ansible.

Agreed, using local connection can be dangerous. I'm just trying to use it
to experiment first before deployment :slight_smile:

Noted for vault encryption. I'll try to have a look soon.

Any idea when the next foreman-ansible release will be? In my opinion the
ability to select the ansible connection is a great feature worth releasing
:slight_smile:

Thanks and have a good day!

Hello Bernard,
what version of foreman-ansible are you running? As far as I know there
wasn't a new release since the winrm support was added, so unless you're
running from git checkout it won't work.

Briefly looking at the code, the commit adding winrm support should also
enable using the local connection adapter, but I would refrain from doing
that. You might end up with roles being applied on wrong host, depending on
whether you use smart proxies for ansible or not

I think there's no support for vaults yet, but it would be a great addition.

Adam

··· On Jan 3, 2017 09:57, "Adam Ruzicka" wrote:

On Mon, Jan 2, 2017 at 11:59 PM, Bernard Landon bernard.landon@gmail.com wrote:

Hello all :smiley:

Quick question, I see there’s a commit on foreman-ansible to support winrm.
I’ve been trying to use it with no success. I’m setting the parameter
"ansible_connection" to winrm, but when running the role, the foreman still
tries to connect over ssh.
Do I need to configure anything else?
Also, should the “local” connection type be also supported? When trying to
use local connection, the foreman also tries to connect over ssh…

Quick yes/no question on an unrelated topic, does the plugin support using
vault password / vault password files?
Could be handy and I would be willing to work on it if someone’s willing
to give me some help (I’m new to Ruby).

Thanks!


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.

To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at https://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “Foreman users” group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/foreman-users/RDuiVok8izM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at https://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.

> Hi Adam,
>
> Thanks for your answer.
> Indeed I built new gems from git hub and added them to the foreman gems.
> Here again, I'm not so familiar with Ruby but I suspect it worked since I
> see the new settings under settings->ansible.
>
> Agreed, using local connection can be dangerous. I'm just trying to use it
> to experiment first before deployment :slight_smile:
>
> Noted for vault encryption. I'll try to have a look soon.
>
> Any idea when the next foreman-ansible release will be? In my opinion the
> ability to select the ansible connection is a great feature worth releasing
> :slight_smile:

Most likely after https://github.com/theforeman/foreman_ansible/pull/67
is merged I'll release 1.4.0 with that fix.

··· On 01/03, Bernard Landon wrote:

Thanks and have a good day!

On Jan 3, 2017 09:57, “Adam Ruzicka” aruzicka@redhat.com wrote:

Hello Bernard,
what version of foreman-ansible are you running? As far as I know there
wasn’t a new release since the winrm support was added, so unless you’re
running from git checkout it won’t work.

Briefly looking at the code, the commit adding winrm support should also
enable using the local connection adapter, but I would refrain from doing
that. You might end up with roles being applied on wrong host, depending on
whether you use smart proxies for ansible or not

I think there’s no support for vaults yet, but it would be a great addition.

Adam

On Mon, Jan 2, 2017 at 11:59 PM, Bernard Landon bernard.landon@gmail.com > wrote:

Hello all :smiley:

Quick question, I see there’s a commit on foreman-ansible to support winrm.
I’ve been trying to use it with no success. I’m setting the parameter
"ansible_connection" to winrm, but when running the role, the foreman still
tries to connect over ssh.
Do I need to configure anything else?
Also, should the “local” connection type be also supported? When trying to
use local connection, the foreman also tries to connect over ssh…

Quick yes/no question on an unrelated topic, does the plugin support using
vault password / vault password files?
Could be handy and I would be willing to work on it if someone’s willing
to give me some help (I’m new to Ruby).

Thanks!


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.

To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at https://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “Foreman users” group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/foreman-users/RDuiVok8izM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at https://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to the Google Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send an email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at https://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


Daniel Lobato Garcia

@dLobatog
blog.daniellobato.me
daniellobato.me

GPG: http://keys.gnupg.net/pks/lookup?op=get&search=0x7A92D6DD38D6DE30
Keybase: https://keybase.io/elobato