Foreman host complain after stopping puppet agent

Hello,

I'm trying to figure out how to get foreman to stop complaining on the all
hosts page that a host hasn't checked in via the puppet agent. If I setup
create a new host then build it and don't install the puppet agent and run
it then this host won't report that it's never or hasn't checked in in the
past 35 minutes. The only option I can think of is to remove/delete the
host from foreman and recreate it once the puppet agent is no longer.

> Hello,
>
> I'm trying to figure out how to get foreman to stop complaining on the all
> hosts page that a host hasn't checked in via the puppet agent. If I setup
> create a new host then build it and don't install the puppet agent and run
> it then this host won't report that it's never or hasn't checked in in the
> past 35 minutes. The only option I can think of is to remove/delete the
> host from foreman and recreate it once the puppet agent is no longer.

Not sure what you mean about complaining, but if you mean the little 'red'
status, it's possible to disable the configuration status by going to:

Administer > Settings > Puppet tab > "Always show configuration status"

  • set to no

If you create hosts without Puppet smart proxies and this option is set
to no, the status will not take into account Puppet.

··· On 07/25, Edward Clay wrote:


You received this message because you are subscribed to the Google Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send an email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at https://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


Daniel Lobato Garcia

@dLobatog
blog.daniellobato.me
daniellobato.me

GPG: http://keys.gnupg.net/pks/lookup?op=get&search=0x7A92D6DD38D6DE30
Keybase: https://keybase.io/elobato

That setting is already set to "No". I've edited a host and removed Puppet
Environment, Puppet Master and Puppet CA to contain no puppet host. I've
also stopped/disabled the puppet agent and the host shows out of sync and
the status is orange. Not sure what I'm missing here.

··· On Wednesday, 26 July 2017 03:05:01 UTC-6, Daniel Lobato wrote: > > On 07/25, Edward Clay wrote: > > Hello, > > > > I'm trying to figure out how to get foreman to stop complaining on the > all > > hosts page that a host hasn't checked in via the puppet agent. If I > setup > > create a new host then build it and don't install the puppet agent and > run > > it then this host won't report that it's never or hasn't checked in in > the > > past 35 minutes. The only option I can think of is to remove/delete the > > host from foreman and recreate it once the puppet agent is no longer. > > Not sure what you mean about complaining, but if you mean the little 'red' > status, it's possible to disable the configuration status by going to: > > Administer > Settings > Puppet tab > "Always show configuration status" > - set to no > > If you create hosts without Puppet smart proxies and this option is set > to no, the status will not take into account Puppet. > > > > > -- > > You received this message because you are subscribed to the Google > Groups "Foreman users" group. > > To unsubscribe from this group and stop receiving emails from it, send > an email to foreman-user...@googlegroups.com . > > To post to this group, send email to forema...@googlegroups.com > . > > Visit this group at https://groups.google.com/group/foreman-users. > > For more options, visit https://groups.google.com/d/optout. > > > -- > Daniel Lobato Garcia > > @dLobatog > blog.daniellobato.me > daniellobato.me > > GPG: http://keys.gnupg.net/pks/lookup?op=get&search=0x7A92D6DD38D6DE30 > Keybase: https://keybase.io/elobato >

Similer issue I am facing. Can you please share way forward to resolve out of sync issue in forman dashboard after host is removed and puppet is not managing the host.