Foreman-installer behind a http_proxy

Unable to use local proxy
Foreman and Proxy versions:
Foreman 3.1
Distribution and version:
RHEL 8.5
Other relevant data:
Hello everyone,

Hopefully this is something easy, but I’ve been working on setting up a foreman with a discovery image, but unlike my testing environment, on production there’s a http proxy which I do not have control of. Due to this proxy, I’m unable to download the image. See below the output:

[root@machine ~]# foreman-installer \
>   --enable-foreman-proxy-plugin-discovery \
>   --foreman-proxy-plugin-discovery-install-images=true \
>   --foreman-proxy-plugin-discovery-source-url=
2022-02-04 18:36:18 [WARN  ] [boot] Unsetting environment variable 'http_proxy' for the duration of the install.
2022-02-04 18:36:18 [NOTICE] [root] Loading installer configuration. This will take some time.
2022-02-04 18:43:03 [NOTICE] [configure] 1500 configuration steps out of 2002 steps complete.
2022-02-04 18:45:04 [ERROR ] [configure] /Stage[main]/Foreman_proxy::Plugin::Discovery/Foreman_proxy::Remote_file[/var/lib/tftpboot/boot/fdi-image-latest.tar]/File[/var/lib/tftpboot/boot/fdi-image-latest.tar]: Could not evaluate: Could not retrieve file metadata for Request to timed out connect operation after 120.02 seconds

The warning rightfully warns me that the variable is being unset, but without it, I’m unable to download the image. I’ve tried to look up a solution with foreman-installer --full-help but with no luck(it might be there and I had missed it).

Is there a way to preserve the variable in order to not face this error? Or an additional flag to activate? Any other suggestion is welcome too.

Hello all again,

I ended up creating an nginx instance on localhost on a different port and dumped all the needed files there. Not the most elegant of solutions, but it works, and I needed this done.
Thank you anyway for the eventuality that someone that had tried to look into this.