Foreman Job Search Query Preview doesn't work

Problem:
This is a small bug, but when you go to the Run Job page, and enter something in the search query, before you could click preview and it would show a list and name of hosts.

Now I can still click the refresh button, and I get an idea of the number of hosts it found with my query. But if I click preview, nothing happens and no list ever appears. I have tried with Firefox, Chrome, and Brave to rule out a specific browser issue

Expected outcome:
Clicking preview should show the names of hosts that match with the search query

Foreman and Proxy versions:
Foreman 3.1.2

Distribution and version:
CentOS 7.9

image

1 Like

I tried reproducing this on develop and on foreman 3.1.3 and could not.
What I did is:
Open new job page
Enter name ~ * into the search
Click on the refresh button
Click on the eye/preview button
See list of hosts pop out in a modal. if there are no hosts there is still a modal that says “No hosts found.”

2 Likes

@MariaAga thanks for checking, I have another data point!

It looks like this issue only occurs for me on Job Category: Ansible Playbook.

Ever other Job Category (including other Ansible ones like Ansible Power, Ansible Galaxy, etc.) the preview works like you said.

Can you check if this also affects you when you select Ansible Playbook as the job category?

Weird, I was using Ansible Playbook for my tests, also tried to choose a different category and back to Ansible Playbook and still everything works fine me.

This post was flagged by the community and is temporarily hidden.