Foreman Provider for Proxmox and how to configure

I am trying to figure out how to add a provider for Proxmox and configure it. I haven’t been able figure out the proper way to install the provider and configure it. The process for VMware was pretty simple and straight forward. I have heard libvire is the way to go. Any links for suggestions are appreciated.

Hi @dsexton18

Please have a look at the latest documentation for Proxmox: Provisioning Virtual Machines in Proxmox.

Thanks. For the info I must be missing a repo I added the plugin repo [Index of /plugins/3.5/el8/x86_64](https://Plugins repo)

But still missing a repo I suspect

Problem: conflicting requests

  • package rubygem-foreman_fog_proxmox-0.14.0-4.fm3_5.el8.noarch requires rubygem(fog-proxmox) >= 0.14, but none of the providers can be installed
  • package rubygem-foreman_fog_proxmox-0.14.0-4.fm3_5.el8.noarch requires rubygem(fog-proxmox) < 1, but none of the providers can be installed
  • package rubygem-foreman_fog_proxmox-0.14.0-4.fm3_5.el8.noarch requires (rubygem(fog-proxmox) >= 0.14 with rubygem(fog-proxmox) < 1), but none of the providers can be installed
  • nothing provides rubygem(ipaddress) < 1 needed by rubygem-fog-proxmox-0.14.0-2.el8.noarch
  • nothing provides rubygem(ipaddress) >= 0.8 needed by rubygem-fog-proxmox-0.14.0-2.el8.noarch
  • nothing provides (rubygem(ipaddress) >= 0.8 with rubygem(ipaddress) < 1) needed by rubygem-fog-proxmox-0.14.0-2.el8.noarch
    (try to add ‘–skip-broken’ to skip uninstallable packages)

Never mind I figured out the above. When I go to configure Proxmox as a provider I get Unable to save * ERF42-4050 [Foreman::Exception]: Proxmox version Unknown is not semver suitable.

It looks like your using an incompatible Foreman Proxmox plug-in.

You should try to upgrade the plug-in version; looks like you are still using foreman_fog_proxmox 0.14.0 and fog-proxmox 0.14.0 which does not support Proxmox 7.1. See Confirmed support for Proxmox 7.x · Issue #210 · theforeman/foreman_fog_proxmox · GitHub

I tried the latest version 15 from the nightly repo. No joy

I upgrade the Foreman 3.8 now able to add proxmox as a computer resource. I haven’t had a chance to do much testing.

1 Like

Hi there! How did you figure out the above? I get the same error while trying to install the plugin via the RPM.

What verson are you using? For 3.7 and newer use foreman-installer --enable-foreman-plugin-proxmox

I am using proxmox 8.1 or 8.2 check when i get home.

I am using Satellite 6.15 and want to provision VMs through the plugin. I fixed it by downloading the rubygem[ipaddress] RPM manually.

Do I understand you correct, that dependencies are missing? Are they missing in the RPM spec file?

Best regards Bernhard