Foreman public directory redirecting to https

After the latest update to Foreman 3.3 the public directory /usr/share/foreman/public is redirecting to https.
is there some config option somewhere that i can add to not have the public dir redirect to https?

Expected outcome:
public directory not redirecting to https

Foreman and Proxy versions:
Foreman 3.3
Katello 4.5

Foreman and Proxy plugin versions:

Distribution and version:
CentOS 7

Other relevant data:

Looks like starting in Forman 3.3, HTTPS is enforced but has an exclusion for two specific folders - unattended & userdata (not well documented so

I created a folder named unattended in /public and put my tftp boot files there and voilĂ , my PXE boot started working again.

1 Like

For those wondering, I found this Git Merge: Fixes #30122 - remove usage of controller level force_ssl · theforeman/foreman@221d255 · GitHub

Fixes #30122 - remove usage of controller level force_ssl
Foreman’s use case for HTTP-only is provisioning. Many installers, like Red
Hat’s Anaconda or Debian Preseed, either do not support it or make it very hard
to use HTTPS. This is especially hard since often a custom CA is used so the
establishing the trust chain is hard.

Rails 6.1 drops support for controller level force_ssl. This implements our
use-case as options for the ssl middleware. Our use-case is valid, but it is
better to rely on supported features and not to pull a 3rd party gem.

This does not implement a mechanism for plugins to run HTTP-only. This is
because designing a good API proved to be hard and we didn’t see a scenario
where it would be needed.