Foreman with oVirt using Image, boot order

With a mixed environment both using oVirt and some bare metals servers (for example to provision the oVirt hosts) one will want to use the “discovery” feature provided by Foreman and will set the default global PXE template to use “discovery”.
When creating a VM on oVirt using PXE (network) there are no issues, the VM boot with PXE and goes straight into installation.
The problem arise when using an Image based (using oVirt templates), by default Foreman sets the boot order to first network and then hdd but it seems to forget to generate a file on the tftp proxy so that the VM that boots to PXE doesn’t get into discovery mode.

My suggestion is to remove PXE all together from the Boot order when creating a VM using Image based, or at least give the user the option to select it.
Booting from network on a VM that will absolutely have no use of it is wrong and cause a delay in boot anyhow.

From my memory, 3 years ago, this was working so well with VMware.

Foreman does not send any boot order into oVirt, therefore fog-ovirt library fallbacks to default which is:

attrs[:os][:boot] ||= [attrs.fetch(:boot_dev1, OvirtSDK4::BootDevice::NETWORK), attrs.fetch(:boot_dev2, OvirtSDK4::BootDevice::HD)]

VMWare does the same, except in that case Foreman sends explicitly :boot_order => ['network', 'disk'].

We could implement booting from disk in case provisioning is image-based, yeah. Should be pretty straightforward patch.