Getting 404 on a rpm when running yum update

Just ran into a problem I’ve never had before…
I’ve had a repo for RabbitMQ Server ( with immediate download for a while which syncs daily.
I run

yum clean all ; yum update

and I get

rabbitmq-server                                      noarch                          3.9.4-1.el7                                      MyOrg_c7-rabbitmq-server_c7-rabbitmq-server-repo

available amongst other packages.
When say yes to go ahead I then get

(14/23): perl-Digest-1.17-245.el7.noarch.rpm                                                                                                                                                                   |  23 kB  00:00:00 FAILED [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article

If above article doesn't help to resolve this issue please use

(15/23): perl-Digest-SHA-5.85-4.el7.x86_64.rpm

I can see this rpm is in the repo. I’ve re-sync the repo with Advanced Sync → Validate Content Sync
Re-published the Content View and promoted but the same error message is displayed…

In /var/log/httpd/ I can see a 404

10.xx.yy.zz - - [20/Aug/2021:16:40:09 +0000] "GET /pulp/content/MyOrg/upg/c7-view/custom/c7-rabbitmq-server/c7-rabbitmq-server-repo/../noarch/rabbitmq-server-3.9.4-1.el7.noarch.rpm HTTP/1.1" 404 14 "-" "urlgrabber/3.10 yum/3.4.3"

Running “journalctl -f -u pulpcore-content” I see the same 404

Aug 20 16:40:09 pulpcore-content[11491]: [20/Aug/2021:16:40:09 +0000] "GET /pulp/content/MyOrg/upg/c7-view/custom/c7-rabbitmq-server/noarch/rabbitmq-server-3.9.4-1.el7.noarch.rpm HTTP/1.1" 404 172 "-" "urlgrabber/3.10 yum/3.4.3"

What is going on??

Just tried to “Republish Repository Metadata” - Same error…
Not sure if I need to publish a new Content View and Promote again though…
Verified the Content Checksum - all good.

Advanced Sync → Validate Content Sync → Success
Republish Repository Metadata → Success
Publish new Content View → ok
Promote Lifecycle env → ok

yum clean all ; yum update
is ok now.

1 Like