Hammer doesn't read specified ss_ca_file in foreman.yml config file

**Problem:Hammer Failed Because of SSL verification fails

Expected outcome: hammer ping is good

**Foreman and Proxy versions:3.9.1

**Foreman and Proxy plugin versions:rubygem-hammer_cli.noarch 3.9.0-1.el8

Distribution and version:

Other relevant data:

command line: Hammer ping
result: failed because using a wrong ssl_ca_file (please notice that the ss_ca_file is wrong in below outcome pic)

Check the hammer config file of “/etc/hammer/cli.modules.d/foreman.yml”
ssl_ca_file in config file is correct:

The template workaround is adding a parameter of --ssl-ca-file /etc/pki/katello/certs/katello-server-ca.crt in hammer command line. Would you please help with finding the cause why hammer is using wrong ssl_ca_file, even the config file is correct? Thank you

is there maybe a /root/.hammer/cli.modules.d/foreman.yml that overrides that?

Hi @evgeni , yes, after I revised the ssl_ca_file in the config file of/root/.hammer/cli.modules.d/foreman.yml . It works. Thank you

1 Like