Help with Foreman Development Environment Setup on Oracle Linux 9


Trying to setup foreman development environment (centos-katello-devel) on Oracle Linux 9 using forklift as per this manual.

Initially when I try to bring up the machine using vagrant with libvirtd l I run into the following error:

TASK [foreman_installer_devel_scenario : Set katello_devel_branch] *************
fatal: [centos8-katello-devel]: FAILED! => 
  msg: |-
    The conditional check 'katello_repositories_version != 'nightly'' failed. 
    The error was: error while evaluating conditional (katello_repositories_version != 'nightly'): 'katello_repositories_version' is undefined. '

I try to address this by adding the variable ‘katello_repositories_version’ to vagrant/boxes.d/99-local.yaml and set the value to 4.11.

Thereafter, I run into the following error:

TASK [foreman_installer_devel_scenario : Clone latest puppet-katello_devel] ****
fatal: [centos8-katello-devel]: FAILED! => changed=false 
  cmd: /bin/git checkout --force KATELLO-4.11
  msg: Failed to checkout KATELLO-4.11
  rc: 1
  stderr: |-
    error: pathspec 'KATELLO-4.11' did not match any file(s) known to git
  stderr_lines: <omitted>
  stdout: ''
  stdout_lines: <omitted>

I am unsure of how to proceed. Trying to identify the steps that I am missing so that I can complete the setup of this build environment. I’ll be thankful for any guidance.

Thank you

Running into the same problem with Fedora 39.