Host does not see new repository after subscribing

I have created a new repository for installing Open OnDemand but after I subscribed my host, it does not see that repository when I do a yum repolist.

Steps I took:

  • Created a product and yum repository called OOD and uploaded packages to it
  • Added the product to a convent view called OOD-BCV (base content view) and published/promoted it
  • Added the OOD-BCV content view to a composite view called FrozenChannel-2019 and published/promoted it
  • Created an activation key called OOD and set it to use the FrozenChannel-2019 content view
  • Enabled the OOD repository under the OOD activation key
  • Set my host to use the FrozenChannel-2019 content view
  • Subscribed my host to the OOD activation key
  • Ran subscription-manager refresh, yum clean all, yum repolist

However, yum repolist does not show the OOD repository (but I can see my others). Nor does subscription-manger repos --list show the repo. I see no failed tasks or any other errors. I have tried rebuilding the host from scratch to no avail either.

I would greatly appreciate if someone could point me towards what Iā€™m doing wrong!

Expected outcome:
After subscribing and refreshing the yum metadata, a yum repolist should show the new repository.

Foreman and Proxy versions:

Foreman and Proxy plugin versions:

Distribution and version:
Katello server: CentOS Linux release 7.6.1810 (Core)
Client: CentOS Linux release 7.4.1708 (Core)


could you please check if you are affected by this problem ? This is quite a common problem recently. :frowning:
Afaik that is not fixed 3.12 (target versoin in Bugzilla is 3.15, so probably not since that is not released yet). The Problem is that Katello generates Certificates that last for 30 years by default, and since 2020 this kills some python SSL library used in subscription-manager.
The easiest way is to check if the subscriptions for your newly generated products have an end date of greater than 31.12.2049.


1 Like

Oh, and welcome to the forum :slight_smile:

1 Like

I am extremely grateful for your help, that was indeed the problem. I have marked this post as solved. And thank you for welcoming me to the forum :slight_smile:

1 Like