HTTP port 80 Foreman already used

When i use foreman installer, it can’t start httpd server du to the port 80 not free and already used. I use this port for another software.

So i run the install with the option --foreman-server-port=8080
But it still try to start httpd on port 80, even when i check with the -i option and 8080 is recorded in the install option.

Can you help ?



the fact that --foreman-server-port does not change the actuall http port sounds like a bug to me. I could not find a corresponding bug report on this topic, so you might want to file one at
Despite that, it is generally recommended to not install Foreman in parallel to other software on the same host (exactly because of problems like this).


I tried this install with 1.22 RC1 could not be stable, i will try with 1.21 stable version and view if it’s only an install bug


It is highly recommended not to install foreman on a server that runs additional services unless you know exactly what you are doing, as the foreman installer will modify multiple configuration files that can cause your other services to fail (Foreman :: Manual).

Yes but my master is based on an Nutanix HyperConverged architecture and have citrix client installed to access it.

Can you change the other software? We really do not test Foreman on hosts without 80 port available and you will run into issues.

Solved, i runned the foreman installer normaly with the option --foreman-server-port=8080
I wait it to finish installation, ignoring port 80 bind error.
After the installation go to /etc/httpd/conf/port.conf and delete the line Listen 80
Then start httpd with service httpd start

All worked fine without problems

It surprises me that it’s needed. The only thing I can see is that apache:mod:jk adds it, but that shouldn’t be part of the default install. Other than that it should only be set by vhosts. Is the default vhost installed by any chance?

If you do unattended installations, you may need to set --foreman-unattended-url as well since that by default assumes port 80 as well.