Incorrect kernel version on bootdisk'ed host

Using bootdisk to deploy AlmaLinux 8 host, Anaconda fails with timeout. Noted that xfs and other modules fail to load.
I haven’t built an AlmaLinux host in a few weeks, but it was working fine previously. I may have been running a prior release of Foreman (3.6/Katello 4.8) the last time I deployed an AlmaLinux VM.

uname -a shows the host boots with kernel 4.18.0-425. Modprobes are failing (for things like xfs) as not found. /usr/lib/modules contains a directory for kernel 4.18.0-477, not 425.

From the syslog on the host: BOOT_IMAGE=BOOT/ALMALINUX_8_BASE_293_VMLINUZ initrd=BOOT/ALINUX_8_BASE_293_INITRD_IMG… (noting that it’s curious it shows ALINUX instead of ALMALINUX for the initrd)

A bit of snooping in the vmlinuz file in /var/lib/tftpboot/boot reveals that it’s a kernel for 4.18.0-477, so it appears that’s not what the system is chain booting from.

Expected outcome:
Booted kernel and initrd line up

Foreman and Proxy versions:
Foreman 3.7.0-1 on EL8 (Rocky 8), Katello 4.9.1-1
Proxy 3.7.0-1 (on the Foreman server)

Foreman and Proxy plugin versions:

Distribution and version:
AlmaLinux 8 for the VM I’m trying to build.

Other relevant data:
I’ve tried manually deleting files from /var/lib/tftpboot/boot.
I’ve tried flushing caches on the Foreman host, foreman-rake tmp:cache:clear
I’ve stopped and started services with foreman-maintain service stop/start
Files in /var/lib/tftpboot for this host (grub/pxelinux/etc) all seem to point to:
Downloading this file directly, it appears to be a 4.18.0-477 kernel (a quick search in the file). No idea how the system is booting a 425 kernel.