Infoblox dhcp smart proxy not populating

Problem: I’m trying to install infoblox dhcp plugin and I see the smart proxy never populates.


Expected outcome:
DHCP smart proxy listed

Foreman and Proxy versions: 3.15

Foreman and Proxy plugin versions:

foreman-tasks The goal of this plugin is to unify the way of showing task statuses across the Foreman instance. It defines Task model for keeping the information about the tasks and Lock for assigning the tasks to resources. The locking allows dealing with preventing multiple colliding tasks to be run on the same resource. It also optionally provides Dynflow infrastructure for using it for managing the tasks. Ivan Nečas 1.1.3
katello Katello adds Content and Subscription Management to Foreman. For this it relies on Candlepin and Pulp. N/A

Pulp, Pulpcore, Templates, TFTP, Puppet CA, Puppet, Logs, and HTTPBoot

Distribution and version: 3.15

Other relevant data:

I’m using $vars in a script

foreman-installer --scenario katello --enable-foreman-proxy-plugin-dhcp-infoblox \
--foreman-proxy-dhcp-provider infoblox \
--foreman-proxy-plugin-dhcp-infoblox-record-type host \
--foreman-proxy-dhcp-server $infoblox_server \
--foreman-proxy-plugin-dhcp-infoblox-username admin \
--foreman-proxy-plugin-dhcp-infoblox-password $pw \
--foreman-proxy-plugin-dhcp-infoblox-network-view default \
--foreman-proxy-plugin-dhcp-infoblox-dns-view default

foreman-installer --scenario katello --foreman-proxy-dhcp-range ""

works (so I know my cert is good)

curl -u admin:$pw https://$infoblox_server/wapi/v2.0/network it works

contents of some .yaml’s

[root@katellopredeploy ~]# cat /etc/foreman-installer/custom-hiera.yaml
# This YAML file lets you set your own custom configuration in Hiera for the
# installer puppet modules that might not be exposed to users directly through
# installer arguments.
# For example, to set 'TraceEnable Off' in Apache, a common requirement for
# security auditors, add this to this file:
#   apache::trace_enable: Off
# Consult the full module documentation on,
# or the actual puppet classes themselves, to discover options to configure.
# Do note, setting some values may have unintended consequences that affect the
# performance or functionality of the application. Consider the impact of your
# changes before applying them, and test them in a non-production environment
# first.
# Here are some examples of how you tune the Apache options if needed:
# apache::mod::prefork::startservers: 8
# apache::mod::prefork::minspareservers: 5
# apache::mod::prefork::maxspareservers: 20
# apache::mod::prefork::serverlimit: 256
# apache::mod::prefork::maxclients: 256
# apache::mod::prefork::maxrequestsperchild: 4000
# Here are some examples of how you tune the PostgreSQL options if needed:
# postgresql::server::config_entries:
#   max_connections: 600
#   shared_buffers: 1024MB
[root@katellopredeploy ~]# history | grep yml
  291  cat /etc/foreman-proxy/settings.d/dhcp.yml
  292  cat /etc/foreman-proxy/settings.d/dhcp_infoblox.yml
  294  history | grep yml
[root@katellopredeploy ~]# cat /etc/foreman-proxy/settings.d/dhcp.yml
# Enable DHCP management
# Can be true, false, or http/https to enable just one of the protocols
:enabled: false

# valid providers:
#   - dhcp_isc (ISC dhcp server)
#   - dhcp_native_ms (Microsoft native implementation)
#   - dhcp_libvirt (dnsmasq via libvirt)
:use_provider: dhcp_infoblox
# subnets restricts the subnets queried to a subset, to reduce the query time.
#  -
#  -
[root@katellopredeploy ~]# cat /etc/foreman-proxy/settings.d/dhcp_infoblox.yml
# Configuration file for 'dhcp_infoblox' dhcp provider
# use :server setting in dhcp.yml if you are managing a dhcp server which is not localhost
# use :subnets setting in dhcp.yml if you want to restrict subnets available to smart-proxy
:username: "admin"
:password: "redFNh0tss[]"
# Record type to manage: can be "host" or "fixedaddress"
:record_type: "host"
:dns_view: "default"
:network_view: "default"
[root@katellopredeploy ~]#


what exactly is your problem?
Can you not see the smart-proxy listed at all or is it just missing the DHCP provider?
In the former case (not listed at all) try to set your location and organisation to “any” (the dropdown menus in the top blue bar in the UI). You usually have to assign smart-proxies to Organizations and Locations yourself. That can be done via the smart-proxy’s settings once you found it in “Any”-Context.

1 Like

I don’t see DHCP listed in the list of smart proxies after I installed the smart proxy plugins. What I see are the following
“Pulp, Pulpcore, Templates, TFTP, Puppet CA, Puppet, Logs, and HTTPBoot

but from another server (who someone else installed where infoblox dhcp/dns is working). I see the DHCP smart proxy.

I’ll look into the bit about location/organization to any

Status is same

I think you’re missing the --foreman-proxy-dhcp true option which enables the DHCP module. The Smart Proxy has modules which are the actual Features (as seen in the Foreman). Some modules (like DNS, DHCP and more) have providers which implement the actual functionality.

1 Like
foreman-installer --scenario katello --enable-foreman-proxy-plugin-dhcp-infoblox \
	--foreman-proxy-dhcp-provider infoblox \
	--foreman-proxy-plugin-dhcp-infoblox-record-type host \
	--foreman-proxy-dhcp-server $infoblox_server \
	--foreman-proxy-plugin-dhcp-infoblox-username admin \
	--foreman-proxy-plugin-dhcp-infoblox-password $pw \
	--foreman-proxy-plugin-dhcp-infoblox-network-view default \
	--foreman-proxy-plugin-dhcp-infoblox-dns-view default

I’ve tried with " TRUE" and “=TRUE” and simply without anything after --foreman-proxy-dhcp

but I keep getting

Preparing installation Done
  * Foreman is running at
  * To install an additional Foreman proxy on separate machine continue by running:

  foreman-proxy-certs-generate --foreman-proxy-fqdn "$FOREMAN_PROXY" --certs-tar "/root/$FOREMAN_PROXY-certs.tar"
  * Foreman Proxy is running at
  The full log is at /var/log/foreman-installer/katello.log
./ line 54: --foreman-proxy-dhcp: command not found


--foreman-proxy-dhcp: command not found

you are missing a \ at the end of the second to last line


thank you, marked it as solved. The infoblox wiki doesn’t have that option listed. Once I set that option you specified (marked as solution). I went into subnets and specified my DNS and DHCP provider. Thank you for a job well done!