Install Foreman/Katello on CentOS 8

Hi all,

I’ve been looking everywhere but can’t find package repos to install Foreman/Katello on CentOS 8. I’ve also been unable to find anything that says whether CentOS 8 is supported or not. I understand that CentOS 8 clients are supported, but ideally I’d like to run the server on 8 as well.

Can anyone clarify whether I can use Foreman/Katello on CentOS 8 yet, or whether there’s a timeline for this?

Thanks

ppascher’s reply to my question is pertinent.

Not supported yet, definitely on our plan, can’t tell when tho. My bet is beginning next year but folks might have better picture e.g. @ehelms or @ekohl.

That’s great, thanks. I thought that was probably the case but I couldn’t find it confirmed anywhere.

The current plan is to target the Foreman 2.1 release for EL8 install support.

2 Likes