Installing Debian Bullseye (testing) fails: wrong installer kernel


installing Debian 10 via Foreman and Proxmox/KVM via PXE boot and Preseed provisioning is working just fine, so I tried Debian testing (bullseye) using the cutting edge Foreman 2.5.0-develop .

In /var/log/foreman-proxy/proxy.log

it is shown that the installer is correctly downloaded from and used later for booting via PXELinux template:

URL: [5731056/5731056] -> “/srv/tftp/boot/debian-mirror-INWYhan9FG31-linux” [1]

URL: [29158643/29158643] -> “/srv/tftp/boot/debian-mirror-INWYhan9FG31-initrd.gz” [1]

Unfortunately, the installation fails after ‘download-installer’ succeeded, because:

“anna[…]: WARNNG **: no packages matching running kernel 5.9.0-4-amd64 in archive”


# file linux
linux: Linux kernel x86 boot executable bzImage, version 5.9.0-4-amd64 ( #1 SMP Debian 5.9.11-1 (2020-11-27), RO-rootFS, swap_dev 0x5, Normal VGA

Before this WARNING (aka ERROR), the net-retriever did download

which rather fit kernel-image-5.10.0-3-amd64 (which you can prove by extracting the xz).

Did anyone succeed with installing Debian testing? This is a Debian issue? Testing not yet ready for network installation?

Kind regards,

Foreman and Proxy versions: 2.5.0-develop

Foreman and Proxy plugin versions:

foreman 9999-buster+scratchbuild+20210301155255
foreman-assets 9999-buster+scratchbuild+20210301155255
foreman-cli 9999-buster+scratchbuild+20210301155255
foreman-debug 9999-buster+scratchbuild+20210301155255
foreman-dynflow-sidekiq 9999-buster+scratchbuild+20210301155255
foreman-installer 9999-buster+scratchbuild+20210302031138
foreman-postgresql 9999-buster+scratchbuild+20210301155255
foreman-proxy 9999-buster+scratchbuild+20210218180351
foreman-service 9999-buster+scratchbuild+20210301155255
ruby-foreman-ansible 6.1.1-1
ruby-foreman-ansible-core 4.0.0-2
ruby-foreman-deface 1.5.3-1
ruby-foreman-dhcp-browser 0.0.8-1
ruby-foreman-fog-proxmox 0.12.4-1
ruby-foreman-remote-execution 4.2.2-1
ruby-foreman-remote-execution-core 1.4.0-1
ruby-foreman-tasks 3.0.3-1
ruby-foreman-tasks-core 0.3.4-1
ruby-hammer-cli-foreman 2.3.0-1
ruby-hammer-cli-foreman-ansible 0.3.3-1

Distribution and version: Debian testing / bullseye

I’d try to md5sum the files.

Same problem here. VM boots but fails in the installer with

@m-bucher do you happen to know is this some Debian-related known issue? Maybe something changed in repositories?

You mention Debian Bullseye in the subject which is Debian 11 but in the post you say Debian 10.

So which one?

I am not aware of any breaking changes there, but I must admit I never tried to install Debian testing on foreman.
Also I did not take a detailed look at the repositories.

AFAIK Debian is usually pretty conservative about this.
If it had been Ubuntu it would be possible that something changed :thinking:

1 Like

Debian 10 is fine with Foreman as initially mentioned, just Bullseye (aka Debian 11) does not work yet.
I asked on the debian-user list and got answered what I already assumed: the installer will be updated not automatically each time a new kernel is released:


Thanks for coming back to us.

So I guess we cannot do anything with this.

The people behind the Debian install system might update the netinstall image. I just filed an installation report at

1 Like

Just FYI: meanwhile Debian testing/bullseye installs just fine via Foreman. Except of ansible-runner but that’s beyond this thread.