Installing Foreman with existing instance of Puppet

At work we are already using Puppet, and I am wanting to test Foreman to possibly replace a number of other functions. It is my understanding that I can integrate Foreman with my existing Puppet setup by having Foreman running on a new VM and install a smart proxy on the existing Puppet server and connect the smart proxy in to the Foreman VM. I’ve already started testing this, but I’m getting self signed certificate errors when I try to connect the smart proxy. I didn’t use the foreman-installer I manually installed the foreman-proxy packages and maybe that is my mistake. Is there a way to accept a self signed cert? I can get a cert from a CA but I’d actually prefer the self signed if possible.

Expected outcome:
Integrating new Foreman install with existing Puppet setup.

Foreman and Proxy versions:
Foreman and Proxy plugin versions:
Distribution and version:
Rocky Linux 8.10
Other relevant data:
forman-proxy settings.yml:

:settings_directory: /etc/foreman-proxy/settings.d
:ssl_ca_file: /etc/puppetlabs/puppet/ssl/certs/ca.pem
:ssl_certificate: /etc/puppetlabs/puppet/ssl/certs/
:ssl_private_key: /etc/puppetlabs/puppet/ssl/private_keys/
:bind_host: '*'
:https_port: 8443
:log_file: /var/log/foreman-proxy/proxy.log
:log_level: INFO
:log_buffer: 2000
:log_buffer_errors: 1000

Self signed certificates are not the problem, by default it uses always self signed ones. My assumption would be you installed Foreman on a fresh system without pointing Puppet to the current environment, so you created there new certificates which are not from your Puppet infrastructure while the Smart Proxy uses those from it, resulting in a mismatch. Could this be the case? If yes, replace the certificates on Foreman and it should be fine.

Oh yes that could be the issue they are pointing to different sets of certificates. So if I copy over my existing puppet certs into the Foreman VM I should see better results? I’ll be testing this today. Thank you.

As host certificates are used, not copying them over, just configure Puppet to use your existing environment and generate certificates for the Foreman host. But yes, I hope this is the reason and then it should be the fix.