Installing katello-agent for 3.9 on CentOS6 give dependency error for python-isodate

I’m trying to install the katello-agent on CentOS6 using the instructions at

I’m getting the following dependency error:
-> Running transaction check
—> Package python-pulp-common.noarch 0:2.18.0-2.el6 will be installed
–> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-common-2.18.0-2.el6.noarch
—> Package qpid-proton-c.x86_64 0:0.24.0-1.el6 will be installed
–> Finished Dependency Resolution
Error: Package: python-pulp-common-2.18.0-2.el6.noarch (pulp)
Requires: python-isodate >= 0.5.0-1.pulp
Available: python-isodate-0.4.7-1.el6.noarch (epel)
python-isodate = 0.4.7-1.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Uploading Enabled Repositories Report

Where do I get python-isodate-0.5.0-1 for CentOS6? It’s not in EPEL. I see it in this repository which is listed in the katello 3.8 client install instructions
( but not in the repos listed in the katello 3.9 client install instructions.


Good morning,
I ended up just using the katello 3.8 documentation to install katello-agent-3.3.5-4 which was successful.

Hey Nicole,
Sorry for the delay. Looks like iso-date package didnt get included in pulp 2-18 repo
Filed an issue at Issue #4319: Missing package in 2.18 repo - Infrastructure - Pulp.

Meanwhile for future reference you can separately install before yum installing katello-agent.