Installing VM KVM thin provivistion need ram disk


#1

Problem:
I am getting dracut-initqueue messages when trying to install in KVM thing provision drives I can solve the issue buy using and manual kick start with this following

My template is as follows

install url --url http://kenobie/centos/ 
lang en_US.UTF-8 
selinux --enforcing
 keyboard us 
skipx network --bootproto dhcp --hostname default.geek.dom --device=52:54:00:a2:0d:38 
rootpw -iscrypted <snip>
firewall --service=ssh authconfig --useshadow --passalgo=sha256 --kickstart timezone --utc UTC 
services --disabled gpm,sendmail,cups,pcmcia,isdn,rawdevices,hpoj,bluetooth,openibd,avahi-daemon,avahi-dnsconfd,hidd,hplip,pcscd 
bootloader --location=mbr --append="nofb quiet splash=quiet" 
zerombr 
clearpart --al
l --initlabel autopart 
text
 reboot
 %packages
 yum dhclient ntp wget
 @Core
 redhat-lsb-core
 %end 
%post --nochroot 
exec < /dev/tty3 > /dev/tty3
 #changing to VT 3 so that we can see whats going on.... 
/usr/bin/chvt 3 ( cp -va /etc/resolv.conf /mnt/sysimage/etc/resolv.conf /usr/bin/chvt 1 ) 2>&1 | tee 
/mnt/sysimage/root/install.postnochroot.log 
%end 
%post logger "Starting anaconda default.geek.dom postinstall" 
exec < /dev/tty3 > /dev/tty3 
#changing to VT 3 so that we can see whats going on.... 
/usr/bin/chvt 3 ( # interface real=`grep -l 52:54:00:a2:0d:38 /sys/class/net/*/{bonding_slave/perm_hwaddr,address} 2>/dev/null | awk -F '/' '// {print $5}' | head -1` sanitized_real=`echo $real | sed s/:/_/` cat << EOF > /etc/sysconfig/network-scripts/ifcfg-$sanitized_real BOOTPROTO="dhcp" DOMAIN="geek.dom" DEVICE=$real HWADDR="52:54:00:a2:0d:38" ONBOOT=yes PEERDNS=yes PEERROUTES=yes DEFROUTE=yes MTU=1500 EOF echo "Updating system time" /usr/sbin/ntpdate -sub 0.fedora.pool.ntp.org /usr/sbin/hwclock --systohc rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

Now I remove the above token and just use this it works just fine

LABEL Centos
MENU LABEL CentOs Manual
KERNEL networkboot/centos7/vmlinuz
APPEND initrd=networkboot/centos7/initrd.img ramdisk_size=100000 inst.repo=http://mylocalrepo

Any ideas of what I need to change ?


#2

Do you mean thin provision instead of thing? Honestly I have no idea what you are saying and what your problem is. Describe your setup in more detail, show us the error message and expectations.


#3

Yes I mean thin it has been a long weekend.
the error message I am seeing the client screan is unable to mount /dev/root


#4

I am installing the systems on a Centos 7 box running KVM. Foreman is using Thin Provisioning. I have enclosed a screen shot of the error I am getting.

-rwxr–r-- 1 qemu qemu 193K Mar 4 17:55 fern-mynatt-disk1
selinux is disabled


#5

How much memory does the VM have? Note that RHEL7 requires 2 GB RAM for installation now (it increased).


#6

Yea it has two GB of ram


#7

Ok, one idea - redownload initramdisk and kernel which are dropped on TFTP folder. We’ve seen that the download can go wrong or older Foreman versions can corrupt the files if they are updated upstream. MD5SUM them and/or redownload them.


#8

Thanks I tired that they were the same


#9

The error really looks like corrupted initramdisk, can you share md5sums of them? And URL where you downloaded them from (check in proxy.log).

TFTP protocol can be pretty unreliable (UDP, dropped packets, firewalls blocking it), can you check network side of things?