IPMI/BMC: Power operations are not enabled on this host


A few month ago I have installed foreman 3.8 + katello 4.10 and can provision new Hosts without any problem.

Now I am trying to use the BMC to remotely control power of bare metal Hosts.

In CLI mode I can control the power of the Hosts with ipmitool:

ipmitool  -I lanplus -U xxx -H 192.168.xxx.xxx chassis

I would like to remotely control the power with foreman GUI or hammer. I created an IPMI subnet and added a BMC interface type on the Host within the IMPI subnet.

The foreman-installer has been run with the options :

-foreman-proxy-bmc true --foreman-proxy-bmc-default-provider ipmitool

When I try with hammer, I have:

# hammer host status --id 4
Power operations are not enabled on this host.

On the GUI when I list the Hosts, the power button in front of the Host is inactive. When I do “Select Action/Change Power State” nothing happens when I select a power state even though I have a message “Success”.

The configuration files look good. I have read a few topics on the forum about the same error message but didn’t find a solution.

How could I debug the problem ? What should I check ?
Is there anyone using the bmc feature successfully ?

PS: this is my first post. Sorry if the formatting is not good.

Maybe this previous post will be helpful…

Hello Jeremy,

Thank you for your answer.

To be honest, it was a password problem. The BMC password was mistyped on the Foreman GUI. Sorry !

The link you sent me was about the usage of redfish as BMC provider. So I decided to try it. And when I switched the provider from ipmitool to redfish, I got an understandable message:

Error details for Invalid credentials: <RedfishClient::Connector::AuthError>: Invalid credentials

I then understood that there was a password problem.

With the ipmitool provider the error message was not clear to me:

ERF12-1772 [ProxyAPI::ProxyException]: Unable to perform power BMC operation ([RestClient::BadRequest]: 400 Bad Request) for proxy https://...:9090/bmc

With the right BMC password set under foreman the power management works now no matter the provider I use.

Best regards,


1 Like