Is Ubuntu 22.04 supported with any version of Foreman yet?

Problem:
I want to know if we can install Ubuntu 22.04 with any version of Foreman yet (its in beta). If yes, which version supports it? My Foreman is version 2.5.2 but it wont install Ubuntu 22.04.

Expected outcome:
Ubuntu 22.04 should be installable using internet repositories (Index of /ubuntu/dists/jammy)

Foreman and Proxy versions:
I have Foreman version 2.5 but can upgrade if Ubuntu 22.04 is supported in newer release.

Foreman and Proxy plugin versions:

Distribution and version:

Other relevant data:

1 Like

Hey! Due to some major changes in the provisioning from Ubuntu 20.04.3 on, you’re currently not able to deploy hosts with newer versions (20.10, 22.04) as usual. We’re working on implementing the new so-called Ubuntu autoinstall which replaces the existing debian-installer. This takes some time and requires re-writing of the existing provisioning templates.
Some people got the provisioning working already even though you have to perform a couple of manual steps to get the hosts deployed - see here.

I hope this helps/answers your question.

1 Like

Any news on this?

I can see in the proxy.log the following request:
http://archive.ubuntu.com/ubuntu/dists/jammy/main/installer-amd64/current/legacy-images/netboot/ubuntu-installer/amd64/initrd.gz

But if you try to access the directory via a browser you get:
‘The Legacy Ubuntu Server Installer is no longer available.’
So I guess that is what you meant with ‘replaces the existing debian-installer’?

Hi @LeperMessiah
as far as I can tell, this is still being worked on. See PR9101. I also know @bastian-src is working on this. I will give you an update once there is a working solution in Foreman.

@maximilian sounds good :slight_smile: Thanks.

@maximilian ,

As you might have reading, I worked out a working solution in order to pxe-install ubuntu 20.04 on systems. Probably not the best solution, but at least I provided the solution to the community to implement it in foreman as it should be.

Today I was trying to apply this solution as well to pxe-boot a server with ubuntu 22.04.
The autoinstall using the cloudinit method works.
But when installing the subsciption-manager it ends in an error.
The repo provided by atix, https://apt.atix.de/, is only available for ubuntu 20.04.
So I tried to install this version, but results in the following error:

root@test-ubuntu:/etc/apt# apt-get install -y python3-subscription-manager apt-transport-katello subscription-manager
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-subscription-manager : Depends: python3 (< 3.9) but 3.10.4-0ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.

Any idea when a new version for ubuntu 22.04 will be available?
Otherwise, if possible, configuring the dependency version to ‘=> 3.9’ if this might be the fastest solution.

Thanks in advance for your feedback.

Hi @langesmalle
We are working on providing a built subscription-manager on apt.atix.de. I will keep you up to date.

Maybe something like --ignore-depends helps for now. source: serverfault.com

Hi @maximilian ,
Thanks for your feedback, I will give it a try later on today and will keep you informed.

Hi @maximilian ,

I was able to install it with --ingnore-depends, however, when trying to subscribe my test-server it fails:

root@test-ubuntu:/tmp# subscription-manager register --name="test-ubuntu.cumuli.be" --org='DIDM' --activationkey='Key_Test_Ubuntu' --force
Unable to find Subscription Manager module.
Error: No module named 'iniparse'

And when trying to install the required iniparse package it complains again for the dependency of the python vision for the package python3-subscription-manager:

root@test-ubuntu:/tmp# apt install -y python3-iniparse
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 python3-subscription-manager : Depends: python3 (< 3.9) but 3.10.4-0ubuntu2 is to be installed
                                Depends: python3-dateutil but it is not going to be installed
                                Depends: python3-ethtool but it is not going to be installed
                                Depends: python3-rpm but it is not going to be installed
                                Depends: virt-what but it is not going to be installed
                                Depends: python3-decorator but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

So, I’ll have to wait till the new repo is available, so thanks in advance to keep me up to date.

@maximilian ,

Any news regarding the availability of the repo for Ubuntu 22.04?

Hi @delhi32 , sorry for being so direct, but I need to install the last version of Foreman into Ubuntu 22.04. Did you find any solutions? I would be great if you could share them with me, please. Thanks

Supporting 22.04 would be really great :+1:

@langesmalle Sorry, no update yet, but we still have it on our agenda. Hopefully I can share more news next week!

@maximilian ,

Thanks for your feedback.
I hope it will follow soon as this is realy blocking for in order to install by preference new hardware with ubuntu 22.04 in stead of 20.04.

Hi All,

Is deploying host with Ubuntu 22.04 available? Currently our foreman is on version 1.23 but can be upgraded to 3.3 if deploying ubuntu 22.04 is supported

Foreman server is installed on CentOS 7

ATIX now provides subscription-manager and katello-host-tools for Ubuntu 22.04 “Jammy”: apt.atix.de/Ubuntu22LTS

cc @langesmalle @delhi32 @LeperMessiah @gol19

1 Like

Thank @maximilian for answer,

Just checking also if is possible to make fully unattended installation of host with ubuntu 22.04 as OS from foreman. And does anybody have any link on documentation for this with steps how to do it

Hi @gol19

Yes, it should be. I am currently not aware of any upstream documentation for that, but please have a look at Creating an Installation Medium for Ubuntu 22.04 in orcharhino Documentation. My efforts to bring this upstream has been stalled but will eventually be resumed.

Hope this helps for now!

Thanks for answer, i inastalled 3.30 version in test environement to try deploy ubuntu.
As far as I see debian.rb has hardcoded path to the installer what not exist on jammy version

def pxedir(medium_provider = nil)
# support ubuntu focal(20), which moved pxe files to legacy_image
if (guess_os == ‘ubuntu’ && major.to_i >= 20)
‘dists/$release/main/installer-$arch/current/legacy-images/netboot/’ + guess_os + ‘-installer/$arch’
else
‘dists/$release/main/installer-$arch/current/images/netboot/’ + guess_os + ‘-installer/$arch’
end
end

and also, does anybody know how to open /var/www/html/pub folder to be available on address http://foreman.example.com/pub as i am getting 404 not found error when try access it.

Also i am using 3 templates
PXELinux template - Preseed default PXELinux Autoinstall
UserData Template - Preseed Autoinstall cloud-init user data clone
Finish Template - Preseed default finish

Also i tried to “tweak” Preseed default PXELinux Autoinstall by change last few rows to try get it, but installation going unattended just until I need to start choose language and similar, so only first part finish unattended

DEFAULT linux cloud-init autoinstall
LABEL linux cloud-init autoinstall
KERNEL ubuntu/jammy/vmlinuz
** INITRD ubuntu/jammy/initrd**
APPEND ip=dhcp url=http://<%= @preseed_server %><%= @preseed_path %>22.04-x86_64.iso autoinstall ds=nocloud-net;s=http://10.237.4.114/pub/preseed/autoinstall/<%= @host.shortname %>/ root=/dev/ram0 ramdisk_size=1500000 fsck.mode=skip

<%= snippet_if_exists(template_name + " custom menu") %>

preseed server is remote server with iso and extracted dvd on same location
10.237.4.114 is foreman server, but as pub is not reachable i suppose it could be problem, but i did not suceeded to open it and make it available on foreman server

1 Like

Im stuck at this point as well. Foreman server installed on Ubuntu 20.04, going through the Orcharhino guide linked above, http://foreman.example.com/pub results in 404. Would love some advice on the proper setup procedure.

1 Like