Issue creating a new host

Hi all,
Im new to Foreman - just installed Foreman 1.16 on CentOS7.
Trying to create a host on my vCener but it keep failing (using an image which points to a temmplate) - it finish the creation of the VM, start it but them power it down and delete it.
Here is the relevant lines from the log:

8-03-14 17:00:29 e302f09b [app] [I] Completed 200 OK in 3ms (Views: 0.7ms | ActiveRecord: 0.3ms)
2018-03-14 17:00:29 cf1d1b42 [app] [W] Failed to update a compute vCenter_Pilot (VMware) instance test02: undefined method `[]' for nil:NilClass
 | NoMethodError: undefined method `[]' for nil:NilClass
 | /usr/share/foreman/app/models/compute_resources/foreman/model/vmware.rb:457:in `block in save_vm'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/fog-core-1.45.0/lib/fog/core/collection.rb:18:in `each'
 | /opt/theforeman/tfm/root/usr/share/gems/gems/fog-core-1.45.0/lib/fog/core/collection.rb:18:in `each'
 | /usr/shar

I tried commenting out line 457 per this bug/post:

Didn’t help - any ideas?


It worked after I restarted!

Is there a permanent solution for this? does that means its not possible to add more drives besides what we have on the template?