Issue provisioning after upgrade

After upgrading to latest foreman/katello getting this error on provisioning to vmware.
Worked fine before the upgrade.
Error message when trying to mount the boot ISO - this is all that shows up in any logs:
Failed to attach ISO image to CDROM drive of instance unexpected property name sharedBus

Expected outcome:
no error, host is provisioned

Foreman and Proxy versions:
Foreman 3.10
katello 4.12

Foreman and Proxy plugin versions:

Distribution and version:
RockyLinux 8.9
Other relevant data:
Is there perhaps some option somewhere to increase the logging output from vmware or bootdisk plugins to better find the issue so it can be fixed?

1 Like

This issue has already been reported on the bugtracker and there is also a potential fix linked. This seems to be a bug in fog-vsphere.
As mentioned in the issue, you can try to downgrade fog-vsphere or apply the linked patch locally.


Thank you for that link, completely forgot to check the bug tracker - i just googled around and found nothing.

Manually applied the patch and it seems to have worked.



When this patch will be made available as an official update?

So it sounds like fog-vsphere 3.6.4 fixes the issue? If so, @cintrix84 what do you think about getting the latest fog-vsphere RPM backported to Foreman 3.10 in packaging? Looks like we’re already up to 3.6.5 in the nightly repo (

It looks like 3.6.4 is already in the 3.10 repos, are you wanting 3.6.5 in 3.10?

Hi 3.6.4 does not exist in the 3.10 repository

only rubygem-fog-vsphere-3.6.3

That’s really odd since it should be there when I bumped it back in March:

Update rubygem-fog-vsphere to 3.6.4 · theforeman/foreman-packaging@8ac89af (

@packaging do you know why the rpm didn’t update in the repos?

Core packages are only updated on releases. So this will ship with 3.10.1