Issues upgrading from 1.20.3 RHEL

Over the holiday period we tried performing a forman upgrade using the instructions outlined in the upgrade section of the documentation.

we are currently on version 1.20.3 and trying to upgrade to the latest version. when i tried to perform that upgrade as outlined there seem to have been a number of unavailable dependencies.

I had to revert to the snapshot taken prior to the upgrade.

Is there a path to upgrade from this legacy version to the latest?

We are running this on Redhat 7.8.

Did you try upgrading all versions at once? or one at a time? It is possible that some dependencies which were available when 1.21 came out are no longer present in the RHEL repos, could you provide information on which dependencies were missing?