Katello 3.15 doesn't show available package updates anymore

So one thing on rhel8/centos8 you would use

dnf uploadprofile instead of katello-packages-upload -f

Same thing: at the moment CentOS 8 seems to be fine. Now exception in the logs. The combined profile update tasks end in success state.

I have a PR ready that fixes the nil error which in turn will hopefully sort out your applicability issues. Would you like to try it out? It will also be available in Katello 3.15.2.

Patch: https://github.com/Katello/katello/pull/8738

I have patched upload_profiles.rb. The task is successful, too.

However, it doesn’t affect the applicability count for the centos 7 content hosts. It is still at 0, even though there should be three. katello-package-upload -f doesn’t help. Downgrading a package doesn’t help, either. (Downgrading increases the count on CentOS 8 content hosts, though).

So far the patch doesn’t seem to make a difference on how it is working at the moment. The exception is gone, the count still doesn’t work…

Can we see your /var/lib/rhsm/cache/profile.json on one of the troublesome CentOS 7 clients?

What’s the best way to share that here?

You could upload the file directly to the forum in your reply (Upload button) or private message it to me. If you’d rather it not be on the forum you could email it to me at iballou@redhat.com

I have just sent you a PM with the file.

I downgraded sqlite, i.e. currently it shows an available update to 3.7.17-8.el7_7.1 with yum check-update. Katello shows no applicable updates, though.

On Content - Packages I can see for the 3.7.17-8.el7_7.1 version of sqlite the correct count of installed on hosts, but also 0 applicable & upgradable hosts.

I had the same issue. After upgrade the updates view didn’t show any package on a host. So after I read the thread I did a yum update on foreman and then a foreman-rake db:migrate

Now if I click on Hosts > Content hosts I got an empty page. No hosts is listed. I don’t see any particular error in the logs but I may just miss something.

I also did a apipie:cache after the update as suggested by the db:migrate output. Then I cleared all cookies and stored data in the browser to clear any remnants from the previous version. After that everything worked fine again.

Thanks! doing a forman-rake apipie:cache then cleared cookies and cleared browser cache the content hosts loads file.

I still don’t see the package updates. I did a yum check-update on a host, also I did a katello-package-upload -f . Applicable packages still 0 in Katello. All hosts are CentOS 7.

This is the log file when i do a katello-package-upload -f

foreman.log (9.1 KB)

You have to apply the pull request above to get rid of the exception.

Do you have any hanging tasks?

I have changed the upload_profiles.rb from that PR then the exception is gone, i did yum check-update, etc, but applicable package list is still empty, count is still 0. I don’t have stuck tasks. So I belive we both have the same issue.

Hi @Laszlo,

Are you referring to upgrading your Katello server? If so, can you describe how you did your upgrade and what version you upgraded from?

Unlike Laszlo, my installation was a new 3.15 installation. Only upgraded to 3.15.1 in between, but had issues all the time.

@gvde and @Laszlo could you both show the results of ps aux | grep dynflow ?

There is a chance that you may have an old Dynflow worker that is executing old code.

# ps auxw | grep dynflow
foreman+  25573  0.0  0.1 945512 65460 ?        Sl   May29   1:08 ruby /usr/bin/smart_proxy_dynflow_core -d -p /var/run/foreman-proxy/smart_proxy_dynflow_core.pid
foreman   25581  0.0  0.0   4356   584 ?        Ss   May29   0:00 /usr/bin/scl enable tfm sidekiq -e production -r /usr/share/foreman/extras/dynflow-sidekiq.rb -C /etc/foreman/dynflow/orchestrator.yml
foreman   26254  0.0  0.0   4356   588 ?        Ss   May29   0:00 /usr/bin/scl enable tfm sidekiq -e production -r /usr/share/foreman/extras/dynflow-sidekiq.rb -C /etc/foreman/dynflow/worker.yml
foreman   26262  0.0  0.0   4356   588 ?        Ss   May29   0:00 /usr/bin/scl enable tfm sidekiq -e production -r /usr/share/foreman/extras/dynflow-sidekiq.rb -C /etc/foreman/dynflow/worker-hosts-queue.yml
ps auxw | grep dynflow
foreman    999  0.0  0.0   4356   116 ?        Ss   May30   0:00 /usr/bin/scl enable tfm sidekiq -e production -r /usr/share/foreman/extras/dynflow-sidekiq.rb -C /etc/foreman/dynflow/worker.yml
foreman   1095  0.0  0.0   4356   112 ?        Ss   May30   0:00 /usr/bin/scl enable tfm sidekiq -e production -r /usr/share/foreman/extras/dynflow-sidekiq.rb -C /etc/foreman/dynflow/orchestrator.yml
foreman   1100  0.0  0.0   4356   112 ?        Ss   May30   0:00 /usr/bin/scl enable tfm sidekiq -e production -r /usr/share/foreman/extras/dynflow-sidekiq.rb -C /etc/foreman/dynflow/worker-hosts-queue.yml
foreman+  2274  0.0  0.3 881748 55460 ?        Sl   May30   1:19 ruby /usr/bin/smart_proxy_dynflow_core -d -p /var/run/foreman-proxy/smart_proxy_dynflow_core.pid

Hi @gvde and @Laszlo,

Do you both see the older versions of your packages on your offending content hosts under installed packages?

Another thing to try: Start up the foreman console with foreman-rake console and show me the output of Host.find_by(name: "your host's name here").content_facet.bound_repositories