Katello 3.5, RHEL 7.4 install failure

I am trying to build a test system with Katello(3.5)/Foreman on a redhat system (7.4). When attempting to follow the build process listed at Foreman :: Plugin Manuals with “RedHat Linux Enterprise 7” selected the options are:

yum install -y yum-utils
yum-config-manager --disable "*"
yum-config-manager --enable rhel-7-server-rpms
yum-config-manager --enable rhel-7-server-optional-rpms
yum-config-manager --enable rhel-7-server-extras-rpms

yum -y localinstall https://fedorapeople.org/groups/katello/releases/yum/3.5/katello/el7/x86_64/katello-repos-latest.rpm
yum -y localinstall https://yum.theforeman.org/releases/1.16/el7/x86_64/foreman-release.rpm
yum -y localinstall https://yum.puppetlabs.com/puppetlabs-release-pc1-el-7.noarch.rpm
yum -y localinstall https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
yum -y install foreman-release-scl python-django

yum -y update

yum -y install katello

And here it fails trying to find dependencies. Here is a chunk of that:

Error: Package: tfm-rubygem-responders-2.3.0-1.el7.noarch (foreman)
Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-apipie-params-0.0.5-1.el7.noarch (foreman)
Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-docker-api-1.28.0-2.el7.noarch (foreman-plugins)
Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-fog-1.41.0-2.el7.noarch (foreman)
Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-audited-4.4.1-1.el7.noarch (foreman)
Requires: sclo-ror42-rubygem(activerecord) < 5.2
Error: Package: tfm-rubygem-qpid_messaging-0.34.1-1.el7.x86_64 (katello)
Requires: libruby.so.2.2()(64bit)
Error: Package: tfm-rubygem-sprockets-rails-3.2.0-1.el7.noarch (foreman)
Requires: sclo-ror42-rubygem(activesupport) >= 4.0
Error: Package: tfm-rubygem-fog-openstack-0.1.18-1.el7.noarch (foreman)
Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-ruby_parser-3.6.3-4.el7.noarch (foreman)
Requires: rh-ruby22-ruby(rubygems)

Looking for “rh-ruby22-runtime” and “sclo-ror42-runtime” ?

Anyone have suggestions on how to get past this? I can’t find either in the repos.

Here is the current repolist on the host.

[root@katello-dev yum.repos.d]# yum repolist
Loaded plugins: product-id, rhnplugin, search-disabled-repos, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
repo id repo name status
epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 12,277
epel-debuginfo/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 - Debug 2,716
epel-source/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 - Source 0
epel-testing/x86_64 Extra Packages for Enterprise Linux 7 - Testing - x86_64 836
epel-testing-debuginfo/x86_64 Extra Packages for Enterprise Linux 7 - Testing - x86_64 - Debug 118
epel-testing-source/x86_64 Extra Packages for Enterprise Linux 7 - Testing - x86_64 - Source 0
foreman/x86_64 Foreman 1.16 450
foreman-plugins/x86_64 Foreman plugins 1.16 304
foreman-plugins-source Foreman plugins 1.16 - source 0
foreman-source Foreman 1.16 - source 0
issredhatrepo ISS RedHat/20180131 Repository 1
katello/x86_64 Katello 3.5 32
katello-candlepin/x86_64 Candlepin: an open source entitlement management system. 3
katello-candlepin-source Katello Candlepin source 0
katello-client/x86_64 Katello Client 3.5 17
katello-client-source Katello Client 3.5 Source 0
katello-pulp/x86_64 Pulp Community Releases 49
katello-pulp-source Katello Pulp source 0
katello-source Katello 3.5 Source 0
puppetlabs-pc1/x86_64 Puppet Labs PC1 Repository el 7 - x86_64 135
puppetlabs-pc1-source Puppet Labs PC1 Repository el 7 - Source 0
rhel-x86_64-server-7 Red Hat Enterprise Linux Server (v. 7 for 64-bit x86_64) 18,035
repolist: 34,973

Howdy,

Installing the foreman-release-scl should enable the CentOS SCL repositories. You may need to try a yum clean all. You are looking for these two repositories to get enabled:

http://mirror.centos.org/centos-7/7/sclo/x86_64/

Eric

2 Likes

Sure enough, the GPG check was failing for that.

The GPG keys listed for the “Foreman 1.16” repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository.

Failing package is: centos-release-scl-rh-2-2.el7.centos.noarch
GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-foreman

I did not notice in all the spam ;( Not sure why it had a bad key, for this test I disabled the gpg test and it installed as expected but… FYI.

Also had to add a /etc/yum.repos.d/CentOS.Base.repo to get it to work:

CentOS-Base.repo

[base]
name=CentOS-$releasever - Base
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os&infra=$infra
baseurl=http://mirror.centos.org/centos/7/os/x86_64/
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

#released updates
[updates]
name=CentOS-$releasever - Updates
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates&infra=$infra
baseurl=http://mirror.centos.org/centos/7/updates/x86_64/
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

#additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras&infra=$infra
baseurl=http://mirror.centos.org/centos/7/extras/x86_64/
gpgcheck=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus
#mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplus&infra=$infra
baseurl=http://mirror.centos.org/centos/7/centosplus/x86_64/
gpgcheck=0
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

You’re on RHEL. That looks extremely dangerous to me

I thought the same but… I couldn’t find “python-twisted-core” and “python-twisted-web” anywhere else.

Suggestions?

These packages have been removed from RHEL

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/migration_planning_guide/sect-red_hat_enterprise_linux-migration_planning_guide-removed_packages

1 Like

You can find those in the PyPI. Install them using pip install twisted-core and pip install twisted-web

1 Like

Trying to work around this bit and still having a bit of trouble. Started from a clean host build (core and base only) and began work.

I did get pip going and installed “twisted”. twisted-core and twisted-web could not be found and seemed twisted was what I was looking for?

Even with those installed and stepping throuhg the install process I see this when I get to “yum install -y katello”

Error: Package: foreman-proxy-1.16.0-1.el7.noarch (foreman)
Requires: rubygem(rake) >= 0.8.3
Error: Package: python-crane-2.1.0-1.el7.noarch (katello-pulp)
Requires: python-flask >= 0.9
Error: Package: pulp-server-2.13.4-1.el7.noarch (katello-pulp)
Requires: python-blinker
Error: Package: python-pulp-streamer-2.13.4-1.el7.noarch (katello-pulp)
Requires: python-twisted-core
Error: Package: python-pulp-streamer-2.13.4-1.el7.noarch (katello-pulp)
Requires: python-twisted-web
Error: Package: python-mongoengine-0.10.5-1.el7.noarch (katello-pulp)
Requires: python-blinker

Seems your dependencies are out of date. Try talking to the Pulp developers, since the issue is with their dependencies.

Which RHEL repositories do y’all have enabled? I think at least extras is needed if not optional as well.

This is what is currently on the host.

repo id repo name status
centos-sclo-rh/x86_64 CentOS-7 - SCLo rh 6,640
centos-sclo-sclo/x86_64 CentOS-7 - SCLo sclo 500
epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 12,289
foreman/x86_64 Foreman 1.16 450
foreman-plugins/x86_64 Foreman plugins 1.16 306
katello/x86_64 Katello 3.5 32
katello-candlepin/x86_64 Candlepin: an open source entitlement management system. 3
katello-client/x86_64 Katello Client 3.5 17
katello-pulp/x86_64 Pulp Community Releases 49
puppetlabs-pc1/x86_64 Puppet Labs PC1 Repository el 7 - x86_64 135
rhel-x86_64-server-7 Red Hat Enterprise Linux Server (v. 7 for 64-bit x86_64) 18,035
repolist: 38,456

For what it’s worth I did add the extras and now have these two for RHEL:

rhel-x86_64-server-7 Red Hat Enterprise Linux Server (v. 7 for 64-bit x86_64) 18,035
rhel-x86_64-server-extras-7 RHEL Server Extras (v. 7 for 64-bit x86_64)

But neither contain python-twisted-*.

I’m having the same problem. Have you found the solution.

repo id repo name status
Candlepin/x86_64 Candlepin 3
Candlepin_Source Candlepin Source 2
CentOS_RH CentOS RH 3,212
Client/x86_64 Client 18
Client_Source Client Source 9
Forman_Plugins/x86_64 Forman Plugins 364
Forman_Plugins_Source Forman Plugins Source 182
Forman_Release Forman Release 244
Forman_Release_Source Forman Release Source 213
Katello/x86_64 Katello 32
Katello_Source Katello Source 20
Pulp/x86_64 Pulp 49
Pulp_Source Pulp Source 17
Puppet_Repo Puppet Repo 42
centos_sclo CentOS SCLO 312

Error Messages…

Error: Package: tfm-rubygem-qpid_messaging-0.34.1-1.el7.x86_64 (Katello)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-foreman_snapshot_management-1.3.0-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-hammer_cli_foreman_docker-0.0.4-2.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-text-1.3.0-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-autoprefixer-rails-5.2.1.3-2.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-foreman_virt_who_configure-0.1.5-1.fm1_15.el7.noarch (Katello)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-css_parser-1.4.7-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-sequel-4.20.0-5.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-logging-1.8.2-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: rubygem-rb-inotify-0.9.7-2.el7.noarch (Forman_Plugins)
           Requires: ruby(release)
Error: Package: tfm-rubygem-ruby2ruby-2.1.3-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-opennebula-4.8.0-4.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-opennebula-4.8.0-4.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-friendly_id-5.1.0-3.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(activerecord) >= 4.0.0
Error: Package: 1:tfm-rubygem-concurrent-ruby-edge-0.2.3-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: foreman-1.15.6-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygem(rake) >= 0.8.3
Error: Package: tfm-rubygem-rabl-0.12.0-2.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(activesupport) >= 2.3.14
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-unf_ext-0.0.6-6.el7.x86_64 (Forman_Plugins)
           Requires: libruby.so.2.2()(64bit)
Error: Package: tfm-rubygem-autoprefixer-rails-5.2.1.3-2.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: katello-selinux-3.0.2-1.el7.noarch (Katello)
           Requires: policycoreutils-python
Error: Package: tfm-rubygem-git-1.2.5-7.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.6.3)(64bit)
Error: Package: tfm-rubygem-deface-1.2.0-1.el7.noarch (Forman_Release)
           Requires: sclo-ror42-rubygem(nokogiri) < 2.0.0
Error: Package: tfm-rubygem-foreman_xen-0.5.2-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-jquery-ui-rails-4.1.2-5.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby
Error: Package: foreman-1.15.6-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygem(rdoc)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.9.3)(64bit)
Error: Package: tfm-rubygem-po_to_json-1.0.1-2.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: 1:tfm-rubygem-angular-rails-templates-1.0.2-1.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-apipie-rails-0.4.0-2.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(rails) >= 4.0
Error: Package: tfm-rubygem-signet-0.6.0-5.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-foreman_setup-5.0.0-1.fm1_13.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-po_to_json-1.0.1-2.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-safe_yaml-1.0.4-2.el7.noarch (Forman_Release)
           Requires: /opt/rh/rh-ruby22/root/usr/bin/ruby
Error: Package: tfm-rubygem-protected_attributes-1.1.3-3.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-foreman_omaha-0.0.3-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-hoe-2.12.3-8.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygems >= 1.3.6
Error: Package: tfm-rubygem-responders-2.3.0-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-facter-2.4.0-3.el7.x86_64 (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-foreman_userdata-0.0.1-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt-qemu.so.0()(64bit)
Error: Package: tfm-rubygem-scoped_search-4.1.2-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: rubygem-tilt-1.3.7-2.el7.noarch (Forman_Plugins)
           Requires: /usr/bin/ruby
Error: Package: tfm-rubygem-azure-0.7.7-1.el7.noarch (Forman_Release)
           Requires: sclo-ror42-rubygem(mime-types) < 4.0
Error: Package: tfm-rubygem-foreman_userdata-0.0.1-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-launchy-2.4.3-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-friendly_id-5.1.0-3.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.3.0)(64bit)
Error: Package: tfm-rubygem-fog-core-1.42.0-1.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem-builder
Error: Package: tfm-rubygem-azure-0.7.7-1.el7.noarch (Forman_Release)
           Requires: sclo-ror42-rubygem(mime-types) >= 1.0
Error: Package: tfm-rubygem-rest-client-1.8.0-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-ldap_fluff-0.4.6-1.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(activesupport)
Error: Package: tfm-rubygem-passenger-4.0.18-9.11.el7.x86_64 (Forman_Plugins)
           Requires: rh-ruby22-rubygems
Error: Package: rubygem-rubyipmi-0.10.0-2.el7.noarch (Forman_Plugins)
           Requires: ruby(release)
Error: Package: tfm-rubygem-bootstrap-datepicker-rails-1.6.1.1-1.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-unf_ext-0.0.6-6.el7.x86_64 (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-fog-libvirt-0.4.1-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-little-plugger-1.1.3-21.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-systemu-2.6.5-1.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.7.7)(64bit)
Error: Package: tfm-rubygem-rbvmomi-1.10.0-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: foreman-1.15.6-1.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(sprockets) < 4
Error: Package: tfm-rubygem-katello-3.4.5-1.el7.noarch (Katello)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-ffi-1.4.0-6.el7.x86_64 (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-little-plugger-1.1.3-21.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-powerbar-1.0.17-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-webpack-rails-0.9.8-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby >= 2.0.0
Error: Package: tfm-rubygem-fog-aws-1.2.0-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt-lxc.so.0(LIBVIRT_LXC_1.0.4)(64bit)
Error: Package: tfm-rubygem-secure_headers-3.4.1-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-hammer_cli_foreman_admin-0.0.6-1.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-foreman_cockpit-2.0.3-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-apipie-params-0.0.5-1.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-graphite-api-0.1.5-4.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-graphite-api-0.1.5-4.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-foreman_graphite-0.0.3-3.fm1_11.el7.noarch (Forman_Release)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-safemode-1.3.1-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-extlib-0.9.16-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-webpack-rails-0.9.8-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-foreman_bootdisk-10.0.2-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-hammer_cli_import-0.11.3-1.el7.noarch (Katello)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt-lxc.so.0(LIBVIRT_LXC_1.0.2)(64bit)
Error: Package: tfm-rubygem-syntax-1.0.0-11.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: foreman-1.15.6-1.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(turbolinks) < 3.0
Error: Package: tfm-rubygem-foreman_digitalocean-1.2.0-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-roadie-3.2.1-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.2.1)(64bit)
Error: Package: tfm-rubygem-activerecord-session_store-0.1.2-2.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(activerecord) < 5
Error: Package: tfm-rubygem-x-editable-rails-1.5.5-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-ldap_fluff-0.4.6-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-hashie-2.0.5-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-addressable-2.3.6-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-fog-1.38.0-1.el7.noarch (Forman_Plugins)
           Requires: /opt/rh/rh-ruby22/root/usr/bin/ruby
Error: Package: 1:tfm-rubygem-concurrent-ruby-1.0.3-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-katello-3.4.5-1.el7.noarch (Katello)
           Requires: rh-ruby22-rubygem(json)
Error: Package: 1:rubygem-sinatra-1.4.7-1.el7.noarch (Forman_Plugins)
           Requires: ruby(release)
Error: Package: rubygem-rubyipmi-0.10.0-2.el7.noarch (Forman_Plugins)
           Requires: ruby(rubygems)
Error: Package: tfm-rubygem-rest-client-1.8.0-1.el7.noarch (Forman_Plugins)
           Requires: /opt/rh/rh-ruby22/root/usr/bin/ruby
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.7.0)(64bit)
Error: Package: tfm-rubygem-activerecord-session_store-0.1.2-2.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: foreman-1.15.6-1.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(mail) >= 2.6
Error: Package: tfm-rubygem-gridster-rails-0.5.6.1-1.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(railties) >= 3.1.0
Error: Package: tfm-rubygem-jquery_pwstrength_bootstrap_4-1.2.2-4.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(railties) >= 3.1
Error: Package: tfm-rubygem-rbvmomi-1.10.0-1.el7.noarch (Forman_Plugins)
           Requires: /opt/rh/rh-ruby22/root/usr/bin/ruby
Error: Package: tfm-rubygem-foreman_omaha-0.0.3-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-jquery_pwstrength_bootstrap_4-1.2.2-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-foreman_abrt-0.0.7-1.fm1_12.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-gettext-3.1.4-6.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.6.4)(64bit)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.8.5)(64bit)
Error: Package: tfm-rubygem-foreman-tasks-0.9.6-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-rbvmomi-1.10.0-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-ruby2ruby-2.1.3-4.el7.noarch (Forman_Plugins)
           Requires: /opt/rh/rh-ruby22/root/usr/bin/ruby
Error: Package: tfm-rubygem-foreman_azure-1.3.1-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-launchy-2.4.3-4.el7.noarch (Forman_Plugins)
           Requires: /opt/rh/rh-ruby22/root/usr/bin/ruby
Error: Package: tfm-rubygem-ruby_parser-3.6.3-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-sshkey-1.9.0-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-google-api-client-0.8.2-5.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-diffy-3.0.1-3.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-opennebula-4.8.0-4.el7.noarch (Forman_Release)
           Requires: sclo-ror42-rubygem(nokogiri)
Error: Package: tfm-rubygem-roadie-3.2.1-1.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(nokogiri) >= 1.5.0
Error: Package: foreman-proxy-1.15.6-1.el7.noarch (Forman_Plugins)
           Requires: rubygem(rake) >= 0.8.3
Error: Package: tfm-rubygem-http-cookie-1.0.2-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-passenger-4.0.18-9.11.el7.x86_64 (Forman_Plugins)
           Requires: /opt/rh/rh-ruby22/root/usr/bin/ruby
Error: Package: tfm-rubygem-foreman_templates-5.0.1-1.fm1_15.el7.noarch (Forman_Release)
           Requires: git
Error: Package: tfm-rubygem-useragent-0.16.8-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-rainbow-2.2.1-1.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-rbvmomi-1.10.0-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygem(json) >= 1.8
Error: Package: tfm-rubygem-gettext_i18n_rails_js-1.0.3-3.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-hirb-unicode-steakknife-0.0.7-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-hirb-0.7.0-9.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-gettext-3.1.4-6.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: katello-selinux-3.0.2-1.el7.noarch (Katello)
           Requires: /usr/sbin/semanage
Error: Package: tfm-rubygem-foreman_chef-0.5.0-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_1.0.5)(64bit)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.9.13)(64bit)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.8.1)(64bit)
Error: Package: tfm-rubygem-rest-client-1.8.0-1.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(mime-types) < 3.0
Error: Package: tfm-rubygem-fog-google-0.1.0-2.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-hammer_cli_foreman-0.10.2-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-domain_name-0.5.20160310-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.2.0)(64bit)
Error: Package: tfm-rubygem-po_to_json-1.0.1-2.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-foreman-tasks-core-0.1.8-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-jenkins_api_client-1.4.1-3.el7.noarch (Katello)
           Requires: rh-ruby22-ruby(release)
Error: Package: rubygem-bundler_ext-0.4.1-1.el7.noarch (Forman_Plugins)
           Requires: rubygem(bundler)
Error: Package: tfm-rubygem-deface-1.2.0-1.el7.noarch (Forman_Release)
           Requires: sclo-ror42-rubygem(nokogiri) >= 1.6.0
Error: Package: tfm-rubygem-quiet_assets-1.0.2-10.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-netrc-0.7.7-7.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-foreman_cockpit-2.0.3-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-get_process_mem-0.2.1-1.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-foreman_omaha-0.0.3-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-ovirt_provision_plugin-1.0.2-1.fm1_13.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-foreman_ansible-1.4.5-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-protected_attributes-1.1.3-3.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(activemodel) < 5
Error: Package: tfm-rubygem-passenger-native-libs-4.0.18-9.11.el7.x86_64 (Forman_Plugins)
           Requires: libruby.so.2.2()(64bit)
Error: Package: tfm-rubygem-logging-1.8.2-4.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(multi_json) >= 1.8.4
Error: Package: tfm-rubygem-audited-4.4.1-1.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(activerecord) < 5.2
Error: Package: tfm-rubygem-jwt-1.2.0-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-foreman_host_rundeck-0.0.2-3.fm1_11.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: 1:rubygem-concurrent-ruby-1.0.3-1.el7.noarch (Forman_Plugins)
           Requires: ruby(rubygems)
Error: Package: tfm-rubygem-fog-xml-0.1.2-4.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-ruby_parser-3.6.3-4.el7.noarch (Forman_Plugins)
           Requires: /opt/rh/rh-ruby22/root/usr/bin/ruby
Error: Package: tfm-rubygem-safemode-1.3.1-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygems
Error: Package: 1:tfm-rubygem-angular-rails-templates-1.0.2-1.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-friendly_id-5.1.0-3.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-apipie-rails-0.4.0-2.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygem(json)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.4.5)(64bit)
Error: Package: tfm-rubygem-rails-i18n-4.0.9-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-activerecord-session_store-0.1.2-2.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(activerecord) >= 4.0.0
Error: Package: tfm-rubygem-commonjs-0.2.7-4.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-jenkins_api_client-1.4.1-3.el7.noarch (Katello)
           Requires: sclo-ror42-rubygem(nokogiri) < 2.0.0
Error: Package: tfm-rubygem-powerbar-1.0.17-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.0.3)(64bit)
Error: Package: 1:tfm-rubygem-angular-rails-templates-1.0.2-1.el7.noarch (Forman_Release)
           Requires: sclo-ror42-rubygem(tilt)
Error: Package: tfm-rubygem-foreman_chef-0.5.0-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-qpid_messaging-0.34.1-1.el7.x86_64 (Katello)
           Requires: libqpidcommon.so.2()(64bit)
Error: Package: tfm-rubygem-graphite-api-0.1.5-4.el7.noarch (Forman_Release)
           Requires: /opt/rh/rh-ruby22/root/usr/bin/ruby
Error: Package: tfm-rubygem-apipie-rails-0.4.0-2.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.9.9)(64bit)
Error: Package: tfm-rubygem-bootstrap-sass-3.3.7-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-dynflow-0.8.34-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-deacon-1.0.0-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-foreman_noenv-0.0.7-1.fm1_14.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.9.8)(64bit)
Error: Package: tfm-rubygem-ruby-libvirt-0.7.0-1.el7.x86_64 (Forman_Plugins)
           Requires: libvirt.so.0(LIBVIRT_0.7.1)(64bit)
Error: Package: tfm-rubygem-foreman_ansible_core-1.1.1-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-sequel-4.20.0-5.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-jgrep-1.3.3-8.el7.noarch (Forman_Release)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-rubygem-jquery-turbolinks-2.1.0-5.el7.noarch (Forman_Plugins)
           Requires: sclo-ror42-rubygem(railties) >= 3.1.0
Error: Package: tfm-rubygem-foreman_abrt-0.0.7-1.fm1_12.el7.noarch (Forman_Release)
           Requires: rh-ruby22-rubygems
Error: Package: tfm-runtime-3.2-9.el7.x86_64 (Forman_Plugins)
           Requires: rh-ruby22-runtime
Error: Package: tfm-runtime-3.2-9.el7.x86_64 (Forman_Plugins)
           Requires: sclo-ror42-runtime
Error: Package: tfm-rubygem-gridster-rails-0.5.6.1-1.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby
Error: Package: tfm-rubygem-foreman_snapshot_management-1.3.0-1.fm1_15.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: tfm-rubygem-foreman_custom_parameters-0.0.2-4.fm1_11.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-net-ssh-gateway-1.2.0-4.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(rubygems) >= 1.2
Error: Package: tfm-rubygem-unf_ext-0.0.6-6.el7.x86_64 (Forman_Plugins)
           Requires: rh-ruby22-ruby(rubygems)
Error: Package: foreman-proxy-1.15.6-1.el7.noarch (Forman_Plugins)
           Requires: rubygem(rkerberos)
Error: Package: tfm-rubygem-qpid_messaging-0.34.1-1.el7.x86_64 (Katello)
           Requires: libruby.so.2.2()(64bit)
Error: Package: tfm-rubygem-foreman_host_extra_validator-0.0.4-1.fm1_13.el7.noarch (Forman_Release)
           Requires: rh-ruby22-ruby(release)
Error: Package: tfm-rubygem-formatador-0.2.1-9.el7.noarch (Forman_Plugins)
           Requires: rh-ruby22-ruby(release)

Unfortunately no, didn’t find a solution. I set the test project aside for now to work on some others but planned to revisit and hoped a new revision would solve it ;(

@nlinux Did you install foreman-scl? That should ensure the correct SCL repositories are installed.

I had exactly the same issue and was able to resolve it with this command:
yum -y install foreman-release-scl python-django --nogpgcheck
after that I went to /etc/yum.reposd/ and disabled gpg check in centos repo.

Thanks to each and everyone. I’m able to fix the issue

Problem seems to be Network as it’s blocking going outside the network.

Used Proxy settings and the installation completed successfully