Katello 4.0, all Repos are localhost

Problem:
I am testing katello 4.0, and after i upgraded, my Repos are “Published At” localhost via web-gui. See image:

image

My /etc/hosts looks correct before and after upgrade, so not sure where localhost was pulled from.

I expect this is causing other issues, as it seems like repos are not Syncing anymore.

I did the upgrade following the nightly guide located here:

https://docs.theforeman.org/nightly/Upgrading_and_Updating/index-katello.html#upgrading_satellite_server_parent

Expected outcome:
Expected Published At to maintain the fqdn.

Foreman and Proxy versions:
Foreman 2.4.0 (single instance)

Foreman and Proxy plugin versions:
foreman-tasks 4.0.1
foreman_remote_execution 4.3.0
katello 4.0.0.rc3.1

Distribution and version:
Centos 7.9

Other relevant data:
I have not found any relevant logs about this error yet.

Any help locating the issue is appreciated.

Hi @barn,

Looks like you found a bug, thanks for reporting it. The installer stopped configuring that url because it was Pulp 2 related, but Katello is still actually using it.

Here’s a workaround that should work for now:
Go to /etc/foreman/plugins/katello.yaml and add the following config under :katello::

:katello:
<snipped>
  :pulp:
    :url: https://yourhostname/pulp/api/v3/

Please note that running the foreman installer will clear out this setting. We’ll work on getting it fixed soon.

I created an issue: Bug #32362: katello pulp url setting in katello.yaml is no longer set by the installer and the default uses localhost rather than FQDN - Katello - Foreman

2 Likes

I noticed that my repos do not resolve on http even though they are configured to:

image

The https address resolved fine.
The http address times out.
This affects all repos.

Is this part of the same bug, or a different issue?

I believe it’s a separate issue because, on my machine with the same localhost bug, I can access both my http and https repositories.

Do the http repositories time out if you try curl them from your Katello server itself?
When you hit the http endpoint, do you see any logs pop up in /var/log/messages from pulpcore-content? Or perhaps any logs in /var/log/httpd/foreman_access.log ?

1 Like

Thanks for feedback! Looks like a network level restriction unrelated to Foreman.

2 Likes

Hit the same here too. Thanks for posting the fix.

2 Likes