Katello 4.1.2 upgrade fails: broken dependency with tfm-rubygem-katello

Hoping to do updates to fix a recent pulp issue that’s been addressed.

But when doing a standard yum update on my centos7 katello server, I am seeing this issue. Any ideas? I’ve tried yum clean all, etc.

Error: Package: tfm-rubygem-katello-4.1.2-1.el7.noarch (katello)
           Requires: tfm-rubygem(foreman-tasks-core) <= 0.3.5
           Removing: tfm-rubygem-foreman-tasks-core-0.3.5-1.fm2_5.el7.noarch (@foreman-plugins)
               tfm-rubygem(foreman-tasks-core) = 0.3.5
           Updated By: tfm-rubygem-foreman-tasks-core-0.3.6-1.fm2_5.el7.noarch (foreman-plugins)
               tfm-rubygem(foreman-tasks-core) = 0.3.6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

An updated Katello release is being worked on:

1 Like

See Tfm-rubygem-katello-4.1.2-1.el7.noarch dependency

I think will use the new task core version. Until then, use --skip-broken.

Excellent. The best kind of issue to make note of is one that’s already in the works being fixed.

Thanks guys!