Katello-Agent is deprecated. Errata is now pushed to guests using remote execute plugin?

Not really a problem, just wondering that, if katello-agent is replaced by remote execution, can apply errata the same way as before? ex: "content–>errata → box errata ID and apply to all hosts.

Expected outcome:
Apply erratas or packages to several batches of hosts

Foreman and Proxy versions: 2.3.3

Foreman and Proxy plugin versions: Katello 3.18; Foreman Remote Execution 4.2.2; Foreman-Tasks 3.0.5

I already setup a guest with ssh keys exchange (waiting on network side to try it out).
Is it expected that after port 22 is opened between Foreman and guest, erratas and packages can be applied?
Can you let me know if my current setup is up-to-date and adequate for these tasks?

Thank you very much for your assistance


Ahh I installed the plugins running:

#foreman-installer --enable-foreman-plugin-remote-execution --enable-foreman-proxy-plugin-remote-execution-ssh

I think this is the correct way…

1 Like



Yes katello-agent is being depreciated and remote execution is now the default. It can do all the things that katello-agent can do so you should be good to go. The installer command you ran turns it on so I will mark this one as solved.

1 Like

Hi cintrix84,

thanks for the reply. Sure mark it as solved.
From my setup would you say I am good to go for the upcoming time?
Also as a rookie with foreman-katello, the execution to enable the plugins was the correct right? (Previous post). Thanks and cheers

Hi @maramorim,

I think you are good to go for the upcoming future. Yeah by default with Katello we enable the Remote Execution feature so we can associate the templates etc. The next step is what you did allows the smart proxy to ssh to the clients to perform the job you select.


Hmmm, something is wrong when trying to apply this errata:

Can it be that katello-agent is running on the background here and remote execution only on scheduled tasks?
Any way to pick up the errata collection in content and apply it?


Content → Errata → Pick a random applicable errata → Apply to the system (Sub task failed) :frowning:

Did you change the default to remote execution?

Check Administer - Settings - Tab Content

The last setting in the list should be “Use remote execution by default”. Set that to “Yes” to use remote execution instead of katello agent by default.

1 Like

Hi @maramorim,

What you hit will be fixed in the next release with better logic around if katello-agent/rex are enabled.

In the interim, can you goto Settings, Content and change Use remote execution by default to true and try again. Also if that does not work there should be a dropdown button, select that and use remote execution.

Sorry for the issues :frowning:


First of all you guys rock. such help in such small space of time. kudos to all the team.

Regarding this issue, from what I tried I can confirm one thing:

  1. If I try to update directly from here:

By “applying to hosts”; it doesn t work. (even changing in settings the default remote execution to yes on content tab).

If I click on the host instead and get the dropdown and specify as cintrix84 said:

Then it works fine:

There is no issue at all @cintrix84 :slight_smile: thanks for the help.

Just wondering if to get that dropdown we have to do it host by host and not in batches.
that could really speed up system patchings.

Cheers all

1 Like

…and I answered it myself…Just do a host collection and the dropdown is available there for massive patching: