Katello-agent on CentOS 7 and Scientific Linux 7

Dear Community Members,

I am using Foreman 1.22 with Katello 3.12 to provision CentOS 7 (rolling) and Scientific Linux 7 (rolling) at an academic site. I use Katello to nightly sync the Katello client rpms from the canonical upstream repository at the url


In the past couple of days a problem has arisen in installing katello-agent on SL 7:

  $ yum -y install katello-agent 
  Error: Package: python-gofer-proton-2.12.1-1.el7.noarch (IT_Services_Katello_Client_x86_64)
           Requires: python-qpid-proton >= 0.9-5
     You could try using --skip-broken to work around the problem

CentOS 7 is fine and comparing matters one can see there that the corresponding package there is


Could someone shed some light on this … is it an upstream issue with Scientific Linux 7?

Many Thanks in Advance and Best Regards

Nick Gresham

The Katello client repositories are deprecated in favor of the Foreman client repositories. https://yum.theforeman.org/client/ has more recent versions. Could you check if it’s still an issue there?

Many thanks for that information. I shall substitute the Foreman client repository you have kindly suggest and report back with the results.

—and yes that did indeed correct the problem, many thanks.

Hi there,

Just add the same behavior by using the same repo as the OP but on a CentOS 6.6 (and using RH Satellite)

The last katello-agent version who provide python-qpid-proton is the 3.3

So i tried the new repo as reported here

But now, yum complain about other missing dependencies:

--> Finished Dependency Resolution
Error: Package: katello-agent-3.5.1-1.el6.noarch (Katello_Agent_katello-agent_el6_x86_64)
           Requires: gofer < 2.12
Error: Package: katello-agent-3.5.1-1.el6.noarch (Katello_Agent_katello-agent_el6_x86_64)
           Requires: gofer >= 2.11.5
Error: Package: katello-agent-3.5.1-1.el6.noarch (Katello_Agent_katello-agent_el6_x86_64)
           Requires: python-gofer-proton >= 2.5
Error: Package: katello-agent-3.5.1-1.el6.noarch (Katello_Agent_katello-agent_el6_x86_64)
           Requires: python-pulp-agent-lib >= 2.6
Error: Package: katello-agent-3.5.1-1.el6.noarch (Katello_Agent_katello-agent_el6_x86_64)
           Requires: pulp-rpm-handlers >= 2.6

Why the packages needed by katello-agent and not provided by OS repo are not in the katello-agent repository ?

Any advices to solve this issue ?

FMPV, my last resort is to fix the katello-agent version to 3.3 on CentOS 6.x



Our solution was to rebuild these packages for CentOS 6 from available source RPMs, and put them in our own internal repo.

We’ve also had to compile the agent packages for EL8-compatible systems, as these aren’t yet being provided by the project.