Katello client for SLES 12 SP5

I am trying to use http://yum.theforeman.org/client/1.24/sles12/x86_64/, but I have two problems for SP5. First it does not find its dependency python-iniparse, which I solved by taking a package from opensuse build server, which is probably not what I should do. Second there is no release package or gpg key or documentation about the key used and it seems they are not signed by the client key.

Expected outcome:
I would like to use the client repository as it is successfully and verify its integrity.

Foreman and Proxy versions:
Foreman 1.24.2
Katello 3.14.1

Distribution and version:
RHEL 7.8 (server)
SLES 12 SP5 (client)

Other relevant data:
I hope @Justin_Sherrill can help here, but help from everyone else is also appreciated!

@Jonathon_Turel any idea about the python-iniparse issue?

@Zhunting any idea about why the suse repos aren’t signed, nor have a client repos rpm?

I worked on katello-host-tools and subscription-manager to get rid of yum on SLES. All these parts are available in these projects. Would be good to create a new version of the sles client.
python-iniparse is still required and needs to taken from opensuse or other sources.

I found another issue when I was ready to do the first real test. When I run the subscription-manager register it complains about [Errno 2] No such file or directory: '/etc/rhsm/syspurpose/syspurpose.json'. Simply creating the file solves the issue, but perhaps this could also be solved also with an update.

Taking a look

I can confirm that python-iniparse is missing from our sles12 repos, but it is in our Koji server: http://koji.katello.org/koji/buildinfo?buildID=26130

Also can confirm that there is some sort of bug in the subscription-manager version we’re providing in that it won’t automatically create /etc/rhsm/syspurpose/syspurpose.json

I see that we’re providing a pretty old version of subscription-manager for SLES, so I’ll investigate getting a newer version in the repos.

1 Like