Katello Installation broken

While attempting to building a new Katello server version 3.18RC1 I am unable to install due to a package requirement of python2-qpid. It appears this package has been removed from the epel repository, making installation of Katello impossible. This was attempted on a fresh Centos 7 minimal installation following the installation guide provided by the documentation. In fact, I followed the guide a week or so ago with no issues.

When following the installation guide, running yum install -y katello should install all the proper packages. Running a --skip-broken doesn’t install the proper packages. I’ve tried to install several other packages, and manually download and install the RPM, but all the google links are dead, and a manual compile doesn’t seem to resolve the dependency either.

[root@lab-cent7-fm ~]# yum -y install katello
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile

  • base: mirrors.umflint.edu
  • centos-sclo-rh: mirrors.usinternet.com
  • epel: d2lzkl7pfhq30w.cloudfront.net
  • extras: mirrors.gigenet.com
  • updates: mirrors.gigenet.com
    Resolving Dependencies
    –> Running transaction check
    —> Package katello.noarch 0:3.18.0-0.1.rc1.el7 will be installed

    —> Package qpid-tools.noarch 0:1.39.0-1.el7 will be installed
    –> Processing Dependency: python2-qpid for package: qpid-tools-1.39.0-1.el7.noarch
    —> Package tfm-rubygem-public_suffix.noarch 0:3.0.3-2.el7 will be installed
    –> Finished Dependency Resolution
    Error: Package: qpid-tools-1.39.0-1.el7.noarch (epel)
    Requires: python2-qpid
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
1 Like

I actually had the same issue when I just attempted to do a complete re-install.
Manually downloading the following package and installing it on the target host got me past this part at least:
Hope it helps as a workaround for now.


Same here


I can confirm the workaround works and lets me install packages.

I however couldn’t find any notes around if the removal from epel was accidental or intentional. However given that the python 2 is no longer supported, I’m suspecting this is probably an intentional action.

For now I’ll hold onto this package, as I’m just starting my journey down Foreman, and will probably be building / rebuilding it several more times.

Thanks everyone!

To make life a little easier, I’ve made a quick repo with only this package in it. Untill we have a more permanent solution:

name=Element Networks

Note, it still requires you to install epel-release as you’ll need the GPG signing key


FWIW, here is the official build as it is on the Fedora infrastructure: https://koji.fedoraproject.org/koji/buildinfo?buildID=1059121

(not that I don’t trust Thulium, just wanted to have an official reference documented here)

1 Like

Do we know, if python2-qpid will be added to EPEL again? If not, will foreman / katello package and ship the python2-qpid package then?


Update: looks like the previous EPEL maintainer started https://copr.fedorainfracloud.org/coprs/g/qpid/qpid/ and we’re going to add that as a dependency. Until updated katello release files are available it’s recommended to manually enable that.


The problem has been registered in Red Hat Bugzilla:

Is this issue related?
When executing the repo installation steps, the following katello package for qpid gets inststalled, which causes yum update to complain.
I was able to bypass it by setting enable = 1, but I suspect it breaks things further down the installer because the installer breaks later in the install process citing package repo locks etc.

from /etc/yum.repos.d/katello.repo

name=Copr repo for qpid owned by @qpid

yum update
Loaded plugins: fastestmirror
Repository 'qpid': Error parsing config: Error parsing "enabled = '@PULP_ENABLED@'": invalid boolean value

Looks like a bad cherry pick. Which version are you on @luckytroll?

Running with 3.17 and following the procedure as per Centos7

Centos Minimal install, updated base packages and added wget, unzip, and the packages for realm/ad join before start of the katello install.

I gave it another run with 18RC1 using the same install on a reverted vm,
still getting errors later in the install run.

2020-12-09 14:28:54 [ERROR ] [configure] /Stage[main]/Pulpcore::Static/Pulpcore::Admin[collectstatic --noinput]/Exec[pulpcore-manager collectstatic --noinput]: Failed to call refresh: ‘pulpcore-manager collectstatic --noinput’ returned 1 instead of one of [0]
2020-12-09 14:28:54 [ERROR ] [configure] /Stage[main]/Pulpcore::Static/Pulpcore::Admin[collectstatic --noinput]/Exec[pulpcore-manager collectstatic --noinput]: ‘pulpcore-manager collectstatic --noinput’ returned 1 instead of one of [0]
2020-12-09 14:29:33 [NOTICE] [configure] 1300 out of 2205 done.
2020-12-09 14:37:06 [ERROR ] [configure] ‘pulpcore-manager migrate --noinput’ returned 1 instead of one of [0]
2020-12-09 14:37:06 [ERROR ] [configure] /Stage[main]/Pulpcore::Database/Pulpcore::Admin[migrate --noinput]/Exec[pulpcore-manager migrate --noinput]/returns: change from ‘notrun’ to [‘0’] failed: ‘pulpcore-manager migrate --noinput’ returned 1 instead of one of [0]
2020-12-09 14:37:07 [ERROR ] [configure] /Stage[main]/Pulpcore::Database/Pulpcore::Admin[migrate --noinput]/Exec[pulpcore-manager migrate --noinput]: Failed to call refresh: ‘pulpcore-manager migrate --noinput’ returned 1 instead of one of [0]
2020-12-09 14:37:07 [ERROR ] [configure] /Stage[main]/Pulpcore::Database/Pulpcore::Admin[migrate --noinput]/Exec[pulpcore-manager migrate --noinput]: ‘pulpcore-manager migrate --noinput’ returned 1 instead of one of [0]

Note that for my install I am using custom certs, but they validated OK with katello-certs-check - in fact, the install command spit out by that tool is what is executed…