Katello Installer for Proxy Server didn't ensure /var/cache permissions

As part of writing internal documentation I’ve removed and installed the Katello Smart Proxy. When I went to test sync between the master and proxy, I was getting permission denied errors.

celery.utils.dispatch.signal:ERROR: (14156-39200) OSError: [Errno 13] Permission denied: ‘/var/cache/pulp/reserved_resource_worker-0@’

After going through the various online solutions, I still had the error. Digging deeper I found that it was because /var/cache had permissions rwxr-x— (750) set on it and owned by root with the root group. Changing that to rwxr-xr-x (755) resolved the problem.

The installer properly created /var/cache/pulp, set to 755 and owned by apache:apache.

To verify the issue persists, I build an temp box and installed the Smart Proxy on it. The /var/cache stayed at 750 and root:root. That caused permission denied errors for Pulp, as I had already seen.

It would appear that a step is needed during the install to make sure /var/cache has 755 permissions.

CentOS 7 - SELINUX Enabled (set to permissive to troubleshoot if permission issue was SELINUX)
Foreman 1.20.1
Foreman-Proxy-Content 3.10