Katello installs for 4.0 and 4.1 are broken due to qpid-proton update in EPEL on EL7

Update: I was no longer able to get the package from the URL posted by @denicfr, but I was able to find this one:

wget ftp://ftp.pbone.net/mirror/archive.fedoraproject.org/epel/8.3.2021-05-20/Everything/x86_64/Packages/q/qpid-proton-c-0.34.0-1.el8.x86_64.rpm

FWIW, you can get the builds directly from Fedora’s Koji at qpid-proton-0.34.0-2.el7 | Build Info | koji

disabling epel repo worked for me


Version locking the qpid-proton packages should also work:

yum install yum-plugin-versionlock
yum versionlock python2-qpid-proton-0.34* qpid-proton-c-0.34*

This way there’s no need to disable epel.

Any ETA on a tfm-rubygem-qpid_proton package release that supports qpid-proton 0.3.5?

I’m migrating an existing environment to 2.3.5/3.18 to 2.4/4.0 and this is a show stopper at the moment.

EPEL only has qpid-proton 0.3.5 in it’s catalog, so unless I go to another source, 0.3.4 isn’t available.

This is the release procedure for Katello 4.0.3 which should include the fix. You can see how far along it is:

Any update on this?

what did it for me:

disable epel repo /etc/yum.repos.d
vim /etc/yum.repos.d/epel.repo (put 1 on 0)

wget https://download-ib01.fedoraproject.org/pub/epel/7/x86_64/Packages/q/qpid-proton-c-0.35.0-1.el7.x86_64.rpm

rpm -ivh ./qpid-proton-c-0.35.0-1.el7.x86_64.rpm

1 Like

I managed to workaround the issue by excluding the packages while updating 3.18.

yum update -x qpid-proton-c,qpid-dispatch-router
1 Like

Giving my vote too, this qpid-proton-c problem blocks any update attempts.

Same issuehere I´m not able to update to 4.0.

http://yum.theforeman.org/katello/4.0 has packages for the new qpid-proton update, so what is the issue you’re seeing?

@evgeni : the issue is for a fresh install of katello 3.18, or update foreman 2.3/katello 3.18 before upgrading to foreman 2.4/katello 4.0.
Can the rpm dependencies beeing corrected for katello 4.0
be backported for katello 3.18 rpms (server & clients) ?

1 Like

Why would you want a fresh install of 3.18, just to upgrade to 4.0?

That said, I think @Jonathon_Turel didn’t plan any more 3.18 updates, so probably no.

But also: I’ve just deployed a 3.18 for fun, and it works just fine. So what is the actual error you’re getting, and when?

Exactly right. Best case scenario - user hits an upgrade bug from 3.18 → 4.0; we work around it somehow. That might mean pushing a fix into the KATELLO-3.18 branch to be applied manually by the user, but nothing beyond that.

Anyone looking to install a fresh Katello system should absolutely install Katello 4.2 which is now GA! :slight_smile:

I installed Katello 4.2-RC2 on a test system, no issues at all. Very excited to see 4.2.0 in GA! Time to wipe my production (3.18) system clean and start new.


I’m actually running into this issue right now. I have Katello 3.18.4 deployed on RHEL7. I’m trying to upgrade to Katello 3.18.5 before upgrading to Katello 4.0.

Should I just skip 3.18.5 and go directly to Katello 4.0?

I’d hate to see you run into some issue with the pulp3 migration for a bug that was addressed in 3.18.5

Can you try adding this copr repo to the box which contains the qpid bits? It might fix up the dependency resolution: @qpid/qpid Copr

1 Like

Thanks for the repository, at least yum doesn’t throw errors about qpid anymore.
Now I can finally update from Foreman 2.5.1/Katello 4.1.0 to the latest patch,
which should fix some of the issues we have.