Katello-nightly-rpm-pipeline 558 failed


#1

Katello nightly pipeline failed:

https://ci.theforeman.org/job/katello-nightly-rpm-pipeline/558/


#2
[[32m INFO[0m [34m2018-11-27T00:03:24[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman_config_entry[db_pending_migration]: Scheduling refresh of Foreman::Rake[db:migrate]
[[32m INFO[0m [34m2018-11-27T00:03:24[0m [36mverbose[0m]  Foreman::Rake[db:migrate]: Scheduling refresh of Exec[foreman-rake-db:migrate]
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: rake aborted!
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: NameError: uninitialized constant Runcible::Extensions::Errata
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/runcible-2.10.0/lib/runcible/extensions/erratum.rb:3:in `<module:Extensions>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/runcible-2.10.0/lib/runcible/extensions/erratum.rb:2:in `<module:Runcible>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/runcible-2.10.0/lib/runcible/extensions/erratum.rb:1:in `<top (required)>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/runcible-2.10.0/lib/runcible.rb:17:in `block in <top (required)>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/runcible-2.10.0/lib/runcible.rb:17:in `each'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/runcible-2.10.0/lib/runcible.rb:17:in `<top (required)>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.10.0.pre.master/lib/katello.rb:14:in `<top (required)>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext/runtime.rb:41:in `block in system_require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext/runtime.rb:37:in `each'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext/runtime.rb:37:in `system_require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext.rb:19:in `block in system_require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext.rb:14:in `each'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext.rb:14:in `system_require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /usr/share/foreman/config/application.rb:17:in `<top (required)>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /usr/share/foreman/Rakefile:1:in `<top (required)>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/rh/rh-ruby25/root/usr/share/gems/gems/rake-12.3.0/exe/rake:27:in `<top (required)>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns:
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: Caused by:
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: LoadError: cannot load such file -- katello
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm-ror52/root/usr/share/gems/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `block in require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm-ror52/root/usr/share/gems/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:253:in `load_dependency'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm-ror52/root/usr/share/gems/gems/activesupport-5.2.1/lib/active_support/dependencies.rb:287:in `require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext/runtime.rb:41:in `block in system_require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext/runtime.rb:37:in `each'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext/runtime.rb:37:in `system_require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext.rb:19:in `block in system_require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext.rb:14:in `each'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/theforeman/tfm/root/usr/share/gems/gems/bundler_ext-0.4.1/lib/bundler_ext.rb:14:in `system_require'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /usr/share/foreman/config/application.rb:17:in `<top (required)>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /usr/share/foreman/Rakefile:1:in `<top (required)>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: /opt/rh/rh-ruby25/root/usr/share/gems/gems/rake-12.3.0/exe/rake:27:in `<top (required)>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]/returns: (See full trace by running task with --trace)
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: Failed to call refresh: '/usr/sbin/foreman-rake db:migrate' returned 1 instead of one of [0]
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman::Rake[db:migrate]/Exec[foreman-rake-db:migrate]: '/usr/sbin/foreman-rake db:migrate' returned 1 instead of one of [0]
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util/errors.rb:157:in `fail'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/type/exec.rb:164:in `sync'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/type/exec.rb:606:in `refresh'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/event_manager.rb:147:in `process_callback'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/event_manager.rb:34:in `block in process_events'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/event_manager.rb:119:in `block in queued_events'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/event_manager.rb:118:in `each'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/event_manager.rb:118:in `queued_events'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/event_manager.rb:33:in `process_events'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:278:in `eval_resource'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:181:in `call'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:181:in `block (2 levels) in evaluate'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:519:in `block in thinmark'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/2.4.0/benchmark.rb:308:in `realtime'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:518:in `thinmark'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:181:in `block in evaluate'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/graph/relationship_graph.rb:121:in `traverse'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction.rb:171:in `evaluate'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:239:in `block (2 levels) in apply'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:519:in `block in thinmark'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/2.4.0/benchmark.rb:308:in `realtime'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:518:in `thinmark'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:238:in `block in apply'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util/log.rb:156:in `with_destination'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/transaction/report.rb:146:in `as_logging_destination'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:237:in `apply'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:186:in `block (2 levels) in apply_catalog'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:519:in `block in thinmark'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/2.4.0/benchmark.rb:308:in `realtime'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:518:in `thinmark'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:185:in `block in apply_catalog'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:232:in `block in benchmark'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/2.4.0/benchmark.rb:308:in `realtime'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:231:in `benchmark'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:184:in `apply_catalog'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:369:in `run_internal'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:237:in `block in run'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/context.rb:65:in `override'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet.rb:260:in `override'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/configurer.rb:211:in `run'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application/apply.rb:355:in `apply_catalog'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application/apply.rb:280:in `block (2 levels) in main'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/context.rb:65:in `override'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet.rb:260:in `override'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application/apply.rb:280:in `block in main'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/context.rb:65:in `override'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet.rb:260:in `override'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application/apply.rb:233:in `main'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application/apply.rb:174:in `run_command'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application.rb:375:in `block in run'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util.rb:667:in `exit_on_fail'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/application.rb:375:in `run'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util/command_line.rb:136:in `run'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util/command_line.rb:73:in `execute'
[[31mERROR[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m] /opt/puppetlabs/puppet/bin/puppet:5:in `<main>'
[[33m WARN[0m [34m2018-11-27T00:03:31[0m [36mverbose[0m]  /Stage[main]/Foreman::Database/Foreman_config_entry[db_pending_seed]: Dependency Exec[foreman-rake-db:migrate] has failures: true

#3

Possible regression in Runcible?


#4

This should now be resolved in runcible 2.10.1, next run will tell us for sure


Katello-nightly-rpm-pipeline 559 failed
Katello-nightly-rpm-pipeline 556 failed
#5

Confirmed this fixes the issue on my fresh dev box today after updating the gem