Katello-nightly-rpm-pipeline 615 failed


#1

Katello nightly pipeline failed:

https://ci.theforeman.org/job/katello-nightly-rpm-pipeline/615/


#2
TASK [foreman_proxy_content : Generate Certs] **********************************
fatal: [pipeline-proxy-nightly-centos7 -> 192.168.121.227]: FAILED! => changed=true 
  cmd:
  - foreman-proxy-certs-generate
  - --foreman-proxy-fqdn
  - pipeline-proxy-nightly-centos7.n60.example.com
  - --certs-tar
  - /root/pipeline-proxy-nightly-centos7.n60.example.com.tar.gz
  delta: '0:00:09.111538'
  end: '2018-12-26 00:11:21.105393'
  msg: non-zero return code
  rc: 21
  start: '2018-12-26 00:11:11.993855'
  stderr: |-
    tput: unknown terminal "unknown"
    tput: unknown terminal "unknown"
    Parameter parent-fqdn invalid: nil is not a valid string
  stderr_lines:
  - 'tput: unknown terminal "unknown"'
  - 'tput: unknown terminal "unknown"'
  - 'Parameter parent-fqdn invalid: nil is not a valid string'
  stdout: Error during configuration, exiting
  stdout_lines: <omitted>
	to retry, use: --limit @/root/.ansible/retry-files/katello_pipeline.retry

#3

Likely related to https://github.com/theforeman/foreman-installer/pull/268 - @ekohl please take a look when you’re back from holidays


#4

The issue is that for some reason Kafo can’t resolve $facts['fqdn'] instead of $::fqdn. This is where the change was introduced:

I suspect it’s the way we dump defaults in kafo that doesn’t handle an array.


#5

Any updates on this? katello nightlies are still failing


#6

Looks like this has been resolved, nightlies are now green.


#7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.