Katello - Red Hat SAP Hana Repositories won't work

I’ve two organizations in Foreman. One with a working Red Hat Virtualization Subscription where the Nodes can get packages from Foreman.
Recently I’ve configured a second organization for colleagues from another department who want to update their SAP Hana servers (on RHEL 7 and 8). I’ve managed to register one test host to foreman. First I’ve copied manually the certs to the regarding directory (/etc/rhsm/ca) - and additionally to /etc/pki/ca-trust/source/anchors. Then I adopted the rhsm.conf to the same content as the working RHV hosts.
A “yum update” returns following:

[root@lxli03-044 yum.repos.d]# yum update
Loaded plugins: product-id, search-disabled-repos, subscription-manager
ST6_Icinga_icinga_stable_el7                                                                                                 | 1.8 kB  
ST6_salt_salt_el7                                                                                                            | 2.1 kB  
https://lxli03-q03.res01.ads.ooe.local/pulp/repos/ST6/Library/CCV_RHEL7_SAP_Hana/content/e4s/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

failure: repodata/repomd.xml from rhel-7-server-e4s-rpms: [Errno 256] No more mirrors to try.
https://lxli03- q03.res01.ads.ooe.local/pulp/repos/ST6/Library/CCV_RHEL7_SAP_Hana/content/e4s/rhel/server/7/7Server/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found

I ensured that the certs are valid - and as already mentioned - another Red Hat product (in the main organization) works fine.

I already tried to install the package from foreman which includes the certs and rhsm.conf but had no luck - still same error. Also I cleaned the yum cache, … etc.

Logs on the host - eg. /var/log/rhsm/rhsm.log or on foreman, /var/log/foreman/production.log contain no helpful errors.

Expected outcome:
“yum update” from RHEL 7 for SAP Hana Hosts succeed

Foreman and Proxy versions:
Foreman 1.24.2

Foreman and Proxy plugin versions:
Katello 3.14.1

Distribution and version:
[root@lxli03-044 rhsm]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.7 (Maipo)

Other relevant data:

Hi @mschau

From the client, are you able to access https://lxli03-q03.res01.ads.ooe.local/pulp/repos/ST6/Library/CCV_RHEL7_SAP_Hana/content/e4s/rhel/server/7/7Server/x86_64/os/repodata/ in a web browser? If so, is the repomd.xml file present there?

If not, regenerating the repo metadata may be worth trying: Content -> Products -> Select the particular product -> Select the particular repository -> Select Action -> Republish Repository Metadata


Thanks for your reply - I’ve already tried that, but that made no difference. In the meantime I came across following link:

In our case we wanted to keep RHEL 7 for SAP hosts on a certain minor version - so we only released RHEL 7.6 for SAP and registered the hosts on that activation key. Apparently ‘yum’ looks for updates on a default URL on our repository which is in this case “7server” (see repo-url above) instead of the url with the minor version in the path (…/server/7/7.6/x86_64/…/) .

very long story short:
You have to set the subscription manager on the hosts to the respective minor version to get that running.

subscription-manager release --set=7.6