Katello Smart Proxy does not sync all of my repos


I am running Katello 3.7 on a CentOS 7.5 server. I am having an issue where one of my Smart Proxies is not syncing all of it’s data from the Katello server.

When use a workstation that is hooked into the smart proxy and do a yum repolist I receive the error:

[Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"

When I look at my smart proxy, it says the last sync was 8/16 @ 08:58:41 UTC. I’ve tried resyncing the repos, using a Optimized Sync, however it never completes and just times out. In fact, I end up having to restart Katello on the Smart Proxy and the Katello server because of the 500 errors I receive on when looking at the Smart Proxies via the UI.

Any suggestions of what I can do?

Thank you.

  • Philippe

So it looks like my Smart Proxies download policies were set to “Immediate” and they were trying to download packages that no longer existed. I set them to “On Demand” and that solved the issue.