Katello synced media returns 404


We’re new to Foreman/Katello and can’t seem to get the kickstart to work using a local repo of CentOS7. If we use an external URL (http://vault.centos.org/7.3.1611/os/x86_64/) for the Installation Media medium path, the kick works great, but when we try and use an internal repo (that’s been synced, so the files exist locally) we get a different error if we use either http or https.

http error is "The requested URL returned error: 404 Not Found.
If I do a curl on the local URL this is correct as it’s https.

The https error is: Peer’s certificate issuer has been marked as not trusted by the user…

I guess should we use the http or https URL? Then how do we get it to work? The file path it complains about failing does exist though.

Any pointers would be amazing!


You need to use http. The deployed host isn’t able to use https because the certificate is missing. Therefore, switch to http and it will work.

OK thanks, but using http I get the error “404 Not Found”.

If I curl the same URL in a terminal using http I get the 404 error but if I use https I get the contents of the directory. Looks like my setup isn’t working.

Here’s an image of my setup

You seem to have Publish via HTTP turned on, which is good. Do you have any unprocessed Tasks? If it’s empty, try to resync the KS repo once again. Looks like Pulp hasn’t published the HTTP yet.

There are no unprocessed tasks, but I did just Republish Repository Metadata and that seemed to have fixed it.

Thanks for the pointers.


Any restarts of tasks/pulp? The message could not be delivered. That solved ok! Cheers.