Katello "Unable to find content with the ID"

Problem: With trying to publish content view there is an error: Katello::Errors::CandlepinError: Unable to find content with the ID “7683”.

Expected outcome: How do i find out which content is causing this error?

Foreman and Proxy versions: Katello 4.5.1

@thalunil have you tried refreshing the subscription manifest first? the task contains some basic routines which try to ensure content in the foreman/katello DB is appropriately matched to content in the candlepin DB.

if that doesn’t help, try enabling debug level logs and grab a complete stack trace of the error that occurs when you reproduce the issue.

Yes, i tried updating and there are a bunch of ID’s which Katello complains about.

Shall i try to aquire a new manifest from Redhat?
(“New subscription allocation”).
What kind (type) of Satellite shall i use when using Katello 4.5.1?


After looking into the “subscription allocation” at the Redhat portal i discovered that under the manifest the subscriptions were missing (e.g. Redhat Infrastructure) and i added them again and re-imported the manifest.

The problems is now gone and the content can be found!