Kickstart CentOS8 from Foreman 2.3.1

Hello All,

**Problem: I tried to kickstart new installation from Kickstart from foreman. I used templates, try to modify or recreate new one, but I’m struggling with same error : 'Anaconda can’t fetch KS file from https://{URL}/unattended/provision?token=XXXXXXXXX for certificate self-signed.
I tried to go directly to the url from my browser and It’s works.
Also I tried to force from https to http to debug, but without any success.

For to be sure I create on same foreman-proxy tftp server, another kickstart, total manually, and point my DHCP to them, and it’s works also if not https but only http, and install going ahead, only problem i need to create all manually also for stop reinstall.
I want to use foreman tools for that instead manually.

**Expected outcome: Install OS

**Foreman and Proxy versions: Foreman 2.3.1, Proxy 2.3.1, Katello 3.18

Foreman and Proxy plugin versions:

**Distribution and version: CentOS 7.9

Other relevant data:
Unfortunately logs I can’t copy log export, because it’s on console and copy and paste is not works, but always refer to one site

I read all but I can’t sort out, someone had same issue, how he sorted out.
I tried also to recreate my template, but a lot of errors coming out.



Red Hat installer (Anaconda) does not support installing from HTTPS, use HTTP.