Kickstart URL from Foreman Master instead of the Remote Smart Proxy

Hello everybody,

I set up an smart proxy to deploy server through Kickstart in an isolated environment. At the moment, the server to be installed can boot from the TFTP server (smart proxy) and gets the vmlinuz and initrd configuration.

Later in the boot process, the server can not start from the configured kickstart server. In the TFTP configuration file, the Foreman master is configured as a kickstart server instead of the smart proxy.

It seems to me that the content of the kickstart tree is not available to the smart proxy server.

I use the content view and the lifecycle environment from the Foreman master for the smart proxy deployment. The smart proxy is in sync. The server deployment in the Foreman Master environment works.


Expected outcome:

  • smart proxy is used for kickstart server URL

Foreman and Proxy versions:

  • 1.22.0 and 1.22.1

Distribution and version:
CentOS 7

There is the template feature which can be enabled on the Smart Proxy. If also enabled for the right resources (subnet IIRC) on the Foreman side (similar to DNS/DHCP/TFTP proxy) then it can proxy the kickstart for you. Mind you that when you turn it on, it doesn’t rewrite the DHCP config so it’s only active for hosts you provision after turning it on.

Thanks, that was the missing configuration. After I selected the Smart Proxy as a “Template Proxy” for the subnet, I was able to install the server.