Latest bootdisk update leaves machine stuck in installation loop

Problem:
Bootdisk seems to be unable to properly unmount the iso and disconnect cdrom, resulting in endless loop of restarting installation process.

Expected outcome:
Installation finishes, ejects iso and disconnects cdrom

Foreman and Proxy versions:
latest updates
Foreman 2.1.1
katello 3.16

Foreman and Proxy plugin versions:

Distribution and version:
CentOS 7

Other relevant data:
If i have the machines console open while it finishes it pops up a prompt that it’s having problems disconnecting and gives option to override and disconnect anyway. Clicking ‘Yes’ causes expected behaviour (eject, disconnect, reboot to OS).
Would be better if this worked correctly without human-interfacing :wink:

VMWare?

Any logs or other relevant data?

I am not following, Foreman via API makes a request to disconnect a bootdisk ISO and VMWare (or whatever you use) shows a dialog box? That does not make any sense. I am blaming the other party not Foreman in this case :slight_smile:

Yes, this is provisioning on VMWare
It seems as though the installer is attempting to disconnect the cdrom without ejecting the iso from the OS first, causing a prompt due to the cdrom being locked by the VM.

Prompt:


Waiting for answer:

Post-answer (clicking Yes):

i may have found the problem.

We are using a slightly modified version of the default Kickstart default provisioning template, but with the last update that introduced the eject/disconnect cdrom changes, it was changed slightly to correctly eject the drive. I didn’t notice these changes in any release notes i read before upgrading and so our custom default kickstart template did not include those changes.

Just went through both side-by-side and updated our version, testing it now.

1 Like

And it worked. In the end the issue boiled down to PEBCAK ( Problem Exists Between Chair and Keyboard )

1 Like

So can you confirm there is nothing wrong neither in our bootdisk plugin nor in our default template? Thanks.

Yes, confirmed that there is nothing wrong on your end.
Just me not paying enough attention to release notes and changes to default templates :slight_smile:

1 Like