Login to SUSE SCC account not working

We use katello 3.12.3 and foreman 1.22.2 with tfm-rubygem-foreman_scc_manager-1.6.3-1.fm1_22.el7.noarch.

This setup works fine in the test environment with direct internet access.

When I run “test connection” in our production environment via a proxy, the connection test fails.

Does the “foreman_scc_manager” need a special configuration for a katello environment with proxy internet access?

Thanks

The SCC plugin is using the configuration variable cdn_proxy set in config/katello.yaml.

That confirms my assumption. The sync of other “products” (RHEL, CentOS …) works without problems via the configured proxy in Katello.

Does that solve your problem? There has been a change in Katello regarding the use of proxies, but that one is not in the Katello 3.12 branch. It should therefore still work in your environment.

The problem still exists. Synchronization of SUSE repositories is not possible.

Can you verify with

SETTINGS[:katello][:cdn_proxy]

in foreman-rake console that your proxy is configured?

The proxy server is displayed to me with the command.

irb(main):002:0> SETTINGS[:katello][:cdn_proxy]
=> {:host=>“http://proxy.domain.int”, :port=>8080, :user=>“XXXXXX”, :password=>“XXXXXX”}

I just checked myself (with v1.7.1) and I can confirm that the Test-Connection does not work.
However, if I save the account (yes, this works :wink:) and start a Sync the Proxy is used.

Can you try this on your system?

I also saved the account. But the synchronization does not work for me. I get an error message.

Looks like the SUSE server is being addressed directly:

[root@XXXXXX ~]# netstat -tnap |grep 130.57.66.27
tcp 0 1 X.X.X.X:57128 130.57.66.27:443 SYN_SENT 2843/dynflow_execut