Master Exclude Filter with Specific Includes / Ordering Filters

In order to defend against software conflicts on my Alma boxes, within my Product/Content View I want to set master exclude all against “*” packages from the EPEL repo then configure includes for specific packages as needed, which I believe is possible.

Within my Content View I’ve created two filters, an “EPEL Exclude All” Exclude filter, and another include filter featuring specific packages (example ‘atop’), both set specifically against the EPEL repo, but I seem to be unable to order this such that the Include packages are available.

Depend on what you read and where, the order of filters is a factor, but even if I delete and recreate the master exclude it looks to jump to the top of the list in the GUI. That said after the recreation the exclude does at least have a higher Filter ID, so I’m unsure if this is a red herring or not.

FILTER ID | NAME                    | DESCRIPTION                        | TYPE | INCLUSION
4         | EPEL Exclude All        |                                    | rpm  | false
2         | EPEL Include Exceptions | Packages permitted from EPEL repo. | rpm  | true

The official documentation however states the following, so this suggests to me that the combination of includes and includes should be inherent anyway:

If using a combination of Include and Exclude filters, publishing a Content View triggers the include filters first, then the exclude filters. In this situation, select which content to include, then which content to exclude from the inclusive subset.

Can anybody think of any reason why this wouldn’t be working for me?


Expected outcome:
Enabling of select packages from EPEL repo.

Foreman and Proxy versions:

I think what’s happening is that it’s including your Include filter, then excluding everything from your Exclude filter (which is everything.)

Try deleting the Exclude filter entirely and see if that does it.

Thanks for the reply @jeremylenz.

Hmm, I’m certain I tried that before posting and it didn’t work (I can’t remember now if I was able to see no packages from EPEL or all, maybe the former), but I’ve done some further testing today using purely Include filters, and it now seems to be behaving as expecting.

I also noticed one of the other local repos on the CV was reporting a 404 when I tried a DNF update, so possible something went slightly screwy with the last Publish. Otherwise probably human error on my part.

All sorted, thank you!

1 Like

Wait, figured it out I think. Looks like I need to take care when specifying packages to select the corresponding architecture, looks like EPEL has some variations between packages: