Medium can't be blank for hammer host create in Foreman 3.1.2 / Katello 4.3

“hammer host create” no longer inheriting medium-id set in hostgroup. In the past, we were able to leave out the --medium-id number when using hammer host create. If I add that value, it is not using the “synced content” required, and I see no option that forces that.

Expected outcome:
Server provisioned instead of “Medium can’t be blank” message when using --hostgroup flag.

Foreman and Proxy versions:
Foreman 3.1.2-2.
Katello 4.3.0
Foreman and Proxy plugin versions:
foreman-tasks 5.2.2
foreman_chef 0.10.0
foreman_discovery 19.0.1
foreman_docker 5.0.0
foreman_puppet 2.0.4
foreman_remote_execution 5.0.3
katello 4.3.0
Distribution and version:
CentOS Linux release 7.9.2009 (Core)
Other relevant data: