Missing Charts on Remote Execution Page

This week I installed Foreman with the Katello and remote execution Plugin. When I tried to update a Package remotly the command itself executed succesfully but the Donut Chart and Host list where missing.

Expected outcome:

Donut Chart and Host list.

Foreman and Proxy versions:


Foreman and Proxy plugin versions:

foreman-tasks: 9.1.1
foreman-remote-execution: 12.0.5
katello: 4.12

Distribution and version:

Rocky Linux 9.3
Kernel Version: 5.14.0-362.24.1.el9_3.0.1.x86_64

Other relevant data:

Installed Packages

  • candlepin-4.3.12-1.el9.noarch
  • candlepin-selinux-4.3.12-1.el9.noarch
  • foreman-3.10.0-1.el9.noarch
  • foreman-cli-3.10.0-1.el9.noarch
  • foreman-dynflow-sidekiq-3.10.0-1.el9.noarch
  • foreman-installer-3.10.0-1.el9.noarch
  • foreman-installer-katello-3.10.0-1.el9.noarch
  • foreman-postgresql-3.10.0-1.el9.noarch
  • foreman-proxy-3.10.0-1.el9.noarch
  • foreman-redis-3.10.0-1.el9.noarch
  • foreman-release-3.10.0-1.el9.noarch
  • foreman-selinux-3.10.0-1.el9.noarch
  • foreman-service-3.10.0-1.el9.noarch
  • katello-4.12.0-1.el9.noarch
  • katello-certs-tools-2.9.0-2.el9.noarch
  • katello-client-bootstrap-1.7.9-2.el9.noarch
  • katello-common-4.12.0-1.el9.noarch
  • katello-repos-4.12.0-1.el9.noarch
  • katello-selinux-5.0.2-1.el9.noarch
  • pulpcore-selinux-2.0.1-1.el9.x86_64
  • python3.11-pulp-ansible-0.20.2-3.el9.noarch
  • python3.11-pulp-certguard-1.7.1-2.el9.noarch
  • python3.11-pulp-cli-0.21.2-5.el9.noarch
  • python3.11-pulp-container-2.16.4-1.el9.noarch
  • python3.11-pulp-deb-3.0.1-1.el9.noarch
  • python3.11-pulp-file-1.15.1-2.el9.noarch
  • python3.11-pulp-glue-0.21.2-3.el9.noarch
  • python3.11-pulp-python-3.10.0-3.el9.noarch
  • python3.11-pulp-rpm-3.23.3-1.el9.noarch
  • python3.11-pulpcore-3.39.11-1.el9.noarch
  • rubygem-foreman-tasks-9.1.1-1.fm3_11.el9.noarch
  • rubygem-foreman_maintain-1.5.1-1.el9.noarch
  • rubygem-foreman_remote_execution-12.0.5-3.fm3_10.el9.noarch
  • rubygem-hammer_cli-3.10.0-1.el9.noarch
  • rubygem-hammer_cli_foreman-3.10.0-1.el9.noarch
  • rubygem-hammer_cli_foreman_remote_execution-0.3.0-1.el9.noarch
  • rubygem-hammer_cli_foreman_tasks-0.0.20-1.el9.noarch
  • rubygem-hammer_cli_katello-1.12.0-0.1.pre.master.el9.noarch
  • rubygem-katello-4.12.0-1.el9.noarch
  • rubygem-pulp_ansible_client-0.20.3-1.el9.noarch
  • rubygem-pulp_certguard_client-1.6.5-1.el9.noarch
  • rubygem-pulp_container_client-2.16.4-1.el9.noarch
  • rubygem-pulp_deb_client-3.0.1-1.el9.noarch
  • rubygem-pulp_file_client-1.15.1-1.el9.noarch
  • rubygem-pulp_ostree_client-2.1.3-1.el9.noarch
  • rubygem-pulp_python_client-3.10.0-1.el9.noarch
  • rubygem-pulp_rpm_client-3.23.2-1.el9.noarch
  • rubygem-pulpcore_client-3.39.9-1.el9.noarch
  • rubygem-smart_proxy_pulp-3.3.0-1.el9.noarch

This could be resolved in rubygem-foreman_remote_execution-13.0.0. Could you upgrade to that and see if the issue goes away?

1 Like

Thank you, it worked!
I changed the source of the foreman plugins from 3.10 to latest. Are there any disadvantages doing this?

I would rather stay on the safe side of things, rex-13.0.0 should be in 3.10 repos by now so you shouldn’t need to do that.

1 Like

Hi all,

I’ve just upgraded my Foreman+Katello instance from 3.9 to 3.10 and I’m facing the exact same issue.

I checked the REX plugin version as stated by @aruzicka : rubygem-foreman_remote_execution-13.0.0-1.fm3_11.el8.noarch

Unfortunately, that does not solve the issue for me :disappointed_relieved:
By the way, jobs are running in the background, but it’s not possible to check in case of errors.

Is there any other things to check/modify to get this back on track ?

Best Regards,

Also, when on a job page, clicking the “Job tasks” button lead to a completely empty page

2024-04-13T21:29:54 [I|app|efa3095b] Processing by ForemanTasks::TasksController#show as HTML
2024-04-13T21:29:54 [I|app|efa3095b]   Parameters: {"id"=>"a5feff2c-86dc-4c2a-a6a2-5cda054c61fa"}
2024-04-13T21:29:54 [I|app|efa3095b]   Rendered /usr/share/gems/gems/foreman-tasks-9.1.1/app/views/foreman_tasks/tasks/show.html.erb within layouts/application (Duration: 13.5ms | Allocations: 4
2024-04-13T21:29:55 [I|app|efa3095b]   Rendered layouts/base.html.erb (Duration: 43.4ms | Allocations: 17031)
2024-04-13T21:29:55 [I|app|efa3095b]   Rendered layout layouts/application.html.erb (Duration: 58.6ms | Allocations: 21463)
2024-04-13T21:29:55 [I|app|efa3095b] Completed 200 OK in 84ms (Views: 58.7ms | ActiveRecord: 4.8ms | Allocations: 23965)

As it is too unstable right now, I’ll rollback the snapshot made before running the upgrade process