Missing Foreman API to Obtain SSH Keys for remote execution

Hi all,

I’ve recently deployed a new instance of foreman + katello with the below install options and I would like to make use of obtain ssh keys for remote execution from the foreman API as mentioned here in the docs Managing Hosts (theforeman.org)

However the foreman server doesn’t listen on port 8443 as mentioned in the docs. Am I missing something obvious?

foreman-installer --scenario katello \
--foreman-initial-organization "MyOrg" \
--foreman-initial-location "US" \
--enable-foreman-plugin-puppet \
--enable-foreman-cli-puppet \
--foreman-proxy-puppet true \
--foreman-proxy-puppetca true \
--enable-puppet \
--puppet-server true \
--enable-foreman-plugin-remote-execution \

Expected outcome:

Foreman and Proxy versions:
foreman: 3.7.0

Foreman and Proxy plugin versions:
foreman-tasks 8.1.1
foreman_puppet 6.0.0
foreman_remote_execution 10.0.5
katello 4.9.1

Distribution and version:
Rocky Linux release 8.8 (Green Obsidian)

Technically speaking this request you’re trying to do is not meant to hit Foreman, but rather a smart-proxy. Because you have katello enabled, the port is not 8443, but 9090. If you look at the same section in katello docs[1] it should be stated there correctly. This port mismatch is a bit unfortunate, but here we are.

[1] - Managing Hosts

@aruzicka thank you! I did indeed look at the wrong docs then. Thanks for pointing that out!