Ms dhcp not pxe loader

I want to implement foreman already in the existing infrastructure and faced some problems.
There is ms dhcp server, by means of it my devices receive addresses in a network, I configured ms dhcp according to documentation connected with ms dhcp, but on ms dhcp established nothing, only edits from foreman and dhcp of the server. Now when you boot via PXE I wrote
"PXE-E55: ProxyDHCP service did not reply to request on port 4011"
"PXE-M0F: Exiting PXE ROM"
Can you direct?Thanks
Expected outcome:
deploy image by using PXE (MS DHCP)
Foreman and Proxy versions:

@Takune - I’m not sure if you have setup your options on your dhcp server but you would need option 60 setup if you are pxeing and offer dhcp requests on the same server. Option 67 if separated - it’s been awhile since I have done Ms dhcp config so I could be out of date -

thanks for the answer!
in my case, the boot files are in /srv/tftp, i see img os in /srv/tftp/boot,
I need to specify a boot file boot pxe in ms dhcp?
can you give an example of 60.67 and 68 parameters?

I am facing kind of the same issue… I found this document:
What will help you… at least it helped me until I faced the issue with UEFI. But for BIOS boot it is working.

Option 60: -as discussed/shown in the link-
Option 66: IP or FQDN of the TFTP/Foreman Server
Option 67: path-to/filename, e.g.: “pxelinux.0” [BIOS] OR “grube2/grubx64.efi” [UEFI]

I hope this helps a bit.
~ Markus

I solved my problem…

  1. follow the guide how to add DHCP Option 60 in a MS DHCP
  2. do the vendor class thing for filter for the right ARCH (link in my other post)
  3. create different policies for x32,x64 BIOS and UEFI
  4. BUT DO NOT offer option 60 in the DHCP reply/offer
    Let me know if that was helpfull :wink: