New foreman setup tftp issue

Hi Team,

I am new to foreman.
I have run some the config and built foreman, setup DHCP/etc smart of my configs below but i seem to have issue with tftp by var/lib/tftpboot is empty, also smartproxy doesnt show dhcp/tftp. any thought?

also screenshot above of the host i am trying to build. I select action build the host but nothing get populated in the var/lib/tftp

Did you enable tftp on the proxy?

appreciate your response. please see output below
i tried to enable it but got the response below

–foreman-proxy-dns true
–foreman-proxy-dns-managed true
–foreman-proxy-dns-interface enp0s3
–foreman-proxy-dhcp true
–foreman-proxy-dhcp-managed true
–foreman-proxy-dhcp-interface enp0s3
–foreman-proxy-dhcp-range “”
–foreman-proxy-tftp true
–foreman-proxy-tftp-managed true

get this error

2023-11-24 22:27:36 [NOTICE] [root] Running installer with log based terminal output at level NOTICE.
2023-11-24 22:27:36 [NOTICE] [root] Use -l to set the terminal output log level to ERROR, WARN, NOTICE, INFO, or DEBUG. See --full-help for definitions.
2023-11-24 22:27:38 [NOTICE] [configure] Starting system configuration.
2023-11-24 22:27:40 [ERROR ] [configure] Could not find resource ‘Package[foreman-cli]’ in parameter ‘require’ (file: /usr/share/foreman-installer/modules/foreman/manifests/cli/plugin.pp, line: 28) on node
2023-11-24 22:27:40 [NOTICE] [configure] System configuration has finished.
There were errors detected during install.
Please address the errors and re-run the installer to ensure the system is properly configured.
Failing to do so is likely to result in broken functionality.

content of the plugin.pp plugin

[root@forman cli]# more plugin.pp

== Hammer plugin

A generic way to install plugins

=== Parameters:

$package:: The package name

$version:: The package version to ensure

define foreman::cli::plugin (
String $package = “${foreman::cli::params::hammer_plugin_prefix}${title}”,
String $version = ‘installed’,
) {

Debian gem2deb converts underscores to hyphens

case $facts[‘os’][‘family’] {
‘Debian’: {
$real_package = regsubst($package,‘_’,‘-’,‘G’)
default: {
$real_package = $package

package { $real_package:
ensure => $version,
# Ensures we are installing after the repositories are set up
require => Package[‘foreman-cli’],
[root@forman cli]#

This looks a lot like you did not only add –foreman-proxy-tftp true but disabled those two as well. I think the error messages are related to those two and thus unrelated to the missing tftp feature on the proxy…

much appreciated. I will close this ticket off. I have another issue but will open a new ticket.